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1 Introduction 
This User Guide continues where the QuickStart Guide ended by providing additional hardware 
details about the Zoom AM1808 EVM, as well as introductory instructions for using Code 
Composer Studio and the included Board Support Library (BSL) files. 

1.1 Scope of Document 
■ This User Guide references specific connectors on the application baseboard and User 

Interface (UI) board. However, the discussion is limited to special use instructions; detailed 
information about the connectors should be referenced on the respective schematic and Bill 
of Material (BOM) documents. See Appendix A for links to these documents. 

■ This User Guide does not provide detailed instructions for the software included with the kits. 
Please refer to the specific User Guides for each respective software product for additional 
information. A list of additional documentation is available in Appendix A. 

1.2 Requirements 
■ It is assumed that the QuickStart Guide has been read in its entirety. See Appendix A for link 

to the QuickStart Guide. 

■ A development PC with CD/DVD drive, USB port, and at least 2 GB of hard drive space. 
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2 Application Baseboard 

2.1 Application Baseboard Features Diagram 
  

 

 

 
 

 

 

 

2.2 Application Baseboard Ethernet Jack 
The Ethernet jack located on the application baseboard is to only be used with the MII PHY; 
whereas the Ethernet jack located on the UI board is to be used only with the RMII PHY. The 
Ethernet controller on the CPU can only talk to one Ethernet PHY at a time. Which Ethernet PHY 
is being used is entirely controlled through software. 

2.3 DIP Switches 
There are two 8-position DIP switches located on the application baseboard at reference 
designators S2 and S7. By default, all of the switches are set to the “OFF” position. 
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The S2 DIP switch is reserved for user application general purpose. The S7 DIP switch controls 
the processor’s boot mode and several FET muxes on the baseboard. Table 2.1 describes the 
function of each switch. 

Table 2.1: S7 DIP Switch Functions 

Switch OFF Position ON Position 

S7:1* Baseboard LCD drive enabled. Baseboard LCD drive disabled. 

S7:2 

Baseboard audio enabled. Associated 
McASP lines connect to baseboard 
audio only. 

Baseboard audio disabled. 
Associated McASP lines are available 
on audio expansion connector. 

S7:3 AM1808 I/O runs at 3.3V AM1808 I/O runs at 1.8V 
S7:4 No connection 
S7:5 BOOT[1] 
S7:6 BOOT[2] 
S7:7 BOOT[3] 
S7:8 BOOT[4] 

*Note: S7:1 indicates slide 1 on the S7 DIP switch, S7:2 indicates slide 2 on 
the S7 DIP switch, and so on. 

A default boot mode has been defined by pulling all boot pins (BOOT[0:7]) to a default state on 
the SOM. The default boot mode is SPI1 Flash; all available boot modes are described in Table 
2.2. 

Table 2.2: S7 DIP Switch Boot Modes 

 
Boot Mode 

DIP Switch Setting—S7[5:8] 
BOOT[4] BOOT[3] BOOT[2] BOOT[1] 
S7:8 S7:7 S7:6 S7:5 

 NOR EMIFA OFF ON ON ON 
 NAND-8 EMIFA OFF OFF OFF ON 
Default SPI1 Flash OFF OFF OFF OFF 
 UART2 ON ON OFF OFF 
 EMU Debug ON OFF OFF ON 



Zoom™ AM1808 EVM User Guide 

PN 1017843A Logic PD, Inc. All Rights Reserved. 4 

3 User Interface (UI) Board 

3.1 UI Board Features Diagram 
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3.2 UI Board Feature Usage 
The components on the UI board run off the same bus, so not every feature can be used at the 
same time. The following features are mutually exclusive of each other: 

□ 48-character LCD panel 
□ Analog-to-Digital Converter (ADC) and Digital-to-Analog Converter (DAC) 
□ Composite video and S-Video inputs 
□ Camera 
□ RMII Ethernet PHY 

The ADC and DAC features may be used independently or at the same time as each other; 
however, they remain exclusive to the other features. Please refer to the UI board schematics for 
more information; a URL for where to download the schematics is available in Appendix A. 

There are no hardware switches or jumpers that the user needs to interact with on the UI board; 
instead, the UI board features are controlled through software. This is something to take into 
consideration if intending to use the UI board with custom software for the SOM. The provided 
Board Support Library (BSL) files may be used as a reference for how software can control UI 
board features. 

3.3 UI Board Ethernet Jack 
The Ethernet jack located on the UI board is to be used only with the RMII PHY; whereas the 
Ethernet jack located on the application baseboard is to only be used with the MII PHY. The 
Ethernet controller on the CPU can only talk to one Ethernet PHY at a time. Which Ethernet PHY 
is being used is entirely controlled through software. 

3.4 48-Character LCD Panel 
The contrast of the 48-character LCD panel on the UI board is controlled through a potentiometer 
located at reference designator R104. This potentiometer is set for optimal viewing resolution 
during manufacture. However, if you are unable to view the readout on the LCD panel, try 
adjusting the potentiometer to set the desired contrast. 

3.5 NAND Flash Socket 
The UI board contains a NAND flash socket that allows for expandable flash memory and ships 
with a 512 MB chip already in the socket. 

The Meritec SMT SOP socket must be opened and closed correctly to ensure that the NAND 
flash chip seats properly and that the socket doors do not break. Detailed instructions for opening 
and closing the socket are available on Meritec’s website at the following URL: 
http://meritec.thomasnet.com/Asset/Application_Notes.pdf  

3.6 NOR Flash 
The UI board includes an onboard 8 MB NOR flash memory chip for customer use. This NOR 
flash is empty when the UI board ships. 

3.7 User Interface Buttons 
Eight user interface buttons are available on the UI board to interact with software. All of the 
buttons run through an I/O switch controlled by I2C. 

4 WLAN and Bluetooth Daughter Card 
The AM1808 EVM includes a WL1271 WLAN (802.11b/g/n) and Bluetooth 2.1 + EDR daughter 
card. Please refer to the Zoom AM1808 EVM QuickStart Guide for steps on how to connect the 
daughter card to the AM1808 EVM.  

http://meritec.thomasnet.com/Asset/Application_Notes.pdf�
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For other documentation relating to this daughter card, please refer to the Texas Instruments wiki 
page on the AM18x wireless connectivity hardware package.1

5 Removing the AM1808 SOM-M1 

 

The following steps will walk you through removing the AM1808 SOM-M1 from the EVM 
baseboard and then reconnecting it. This may be necessary for troubleshooting purposes or if 
you purchase a different AM1808 SOM-M1 that is compatible with your EVM. 

1. IMPORTANT NOTE: A nylon screw keeps the LCD fastened to the baseboard during 
shipment. Remove this screw from the bottom side of the baseboard before attempting 
to eject the LCD.  

Eject the 4.3” LCD by pulling the LCD ejector levers away from the LCD. Remove the LCD 
from the baseboard and set aside. 

 
2. Taking care not to bend the PCB, remove the AM1808 SOM-M1 by applying even pressure 

beneath the PCB edges and pulling up. 

 

                                                      
1 http://processors.wiki.ti.com/index.php/AM18x_Wireless_Connectivity_Hardware_package  

http://processors.wiki.ti.com/index.php/AM18x_Wireless_Connectivity_Hardware_package�
http://processors.wiki.ti.com/index.php/AM18x_Wireless_Connectivity_Hardware_package�
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3. To connect the AM1808 SOM-M1, align the SOM over the three board-to-board connectors. 
Using even pressure, press straight down over the connectors to mate boards. Visually verify 
that all three connectors have fully mated. 

 
4. Connect the 4.3” LCD by inserting into the baseboard LCD connector and pushing down over 

the connector until the LCD ejector levers move to a vertical position. CAUTION: The solder 
points on the LCD connector PCB may be sharp; use caution when connecting the LCD. 

 

6 Connect Blackhawk Emulator 
The AM1808 EVM includes a Blackhawk™ USB100v2 JTAG emulator. 

1. IMPORTANT NOTE: A nylon screw keeps the LCD fastened to the baseboard during 
shipment. Remove this screw from the bottom side of the baseboard before attempting 
to eject the LCD. 

If the 4.3” LCD in connected to the application baseboard, it must be removed prior to 
connecting the Blackhawk emulator. Pull back on the ejector levers until the LCD board 
connector moves up and disengages from the baseboard 60-pin LCD connector.  

2. The Blackhawk emulator connects to the JTAG 20-pin header for ARM core on the 
application baseboard. See Section 2.1 for diagram pointing to the location of this header.  

3. Position the emulator so the ribbon cable extends away from the application baseboard. See 
figure below.  

4. Make sure all of the header pins line up with their respective holes on the PCB connector. 
Press straight-down on the PCB until the header and connector fully mate. (To assist with 
proper positioning of the emulator 20-pin connector, silkscreen printing on the bottom side of 
the PCB calls out the location of pins 1, 2, 19, and 20; these can be used to verify the 
connector holes matchup with their respective header pins on the application baseboard.)  
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5. The 4.3” LCD can now be reconnected to the application baseboard.  

7 Installing Code Composer Studio 
The Zoom AM1808 EVM includes a software DVD containing Code Composer Studio 
(CCStudio). 

1. Insert the Code Composer Studio v4 software DVD into your host PC. 

2. Navigate to the DVD drive and open the files on the CCStudio DVD. Double-click on 
setup_CCS_4.2.x.xxxxx.exe and a splash screen similar to the image below will appear. Click 
the Next button. 

 
3. Follow the on screen instructions until you arrive at the screen for Product Configuration, 

select Platinum Edition.  

4. On the next screen, leave the default ISA items checked. Click the Next button. 

5. Leave the default Component items checked. Click the Next button. 

USB mini-B 
connector 



Zoom™ AM1808 EVM User Guide 

PN 1017843A Logic PD, Inc. All Rights Reserved. 9 

6. Click the Next button to start copying files. 

7. Wait for CCStudio to finish installing; this process can take some time, so please be patient. 

8. Click the Finish button when the installation is complete. You may eject the CCStudio DVD 
at this time. 

8 Running Board Support Library (BSL) Sample Programs 
The BSL sample programs are included to test the different features of the development kit and 
diagnose any potential problems. In order to run these tests, you first have to connect your 
development kit to a PC. 

8.1 Connect EVM to Host PC 
To communicate with the AM1808 EVM using CCStudio, you will need to connect the included 
USB A to mini-B cable to the USB mini-B connector on the Blackhawk emulator (see Section 6) 
and a USB A port on the host PC.  

As soon as the USB cable connects to your host PC, Windows should automatically recognize 
that new hardware has been connected and install the necessary drivers. Power on your AM1808 
EVM, move the S7 DIP switches 7 and 8 to the on position, and continue with the next section. 

8.2 Copy BSL Files to PC 
The Windows CE SD card included with the AM1808 EVM contains the GEL and BSL files. 
These files need to be copied to your host PC. 

1. Insert the SD card into the USB card reader and insert the card reader into a USB port on 
your host PC. 

2. Navigate into the SD card and locate the BSL files directory. 

3. Extract the ZIP archive and save the files to your host PC. (NOTE: The files may be placed 
anywhere on your host PC; however, the original file structure must remain intact.) 

4. For the instructions in this User Guide, it is assumed the files were copied to the root C:\ 
drive. For example: 

C:\AM1808_BSL 

8.3 Launch Code Composer Studio 
1. Launch Code Composer Studio by selecting Start Menu > All Programs > Texas 

Instruments > Code Composer Studio v4.2.0 > Code Composer Studio v4. 
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2. Select a workspace location and then click the OK button. 

 
3. CCStudio will finish launching and a Welcome to Code Composer Studio window will open. 

(NOTE: If you do not have the latest Adobe Flash Player installed on your machine, you will 
be prompted to install. This is required for proper viewing of the Code Composer Studio 
Welcome screen.) 

4. If you do not have a license, select the Activate a License option and click the Use Free 
Limited License button. (NOTE: If you do not have an active Internet connection, you can 
select to Evaluate Code Composer Studio for 30 days. At any time during that period, you 
can change to the Free Limited License by selecting Help > License Options... from the 
CCStudio menu bar and then following the onscreen instructions.) 
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5. You will be redirected to TI’s website to login in with your myTI.com account. Follow all the 
online instructions. After completing the online instructions, you will receive an email 
containing an attachment that is your license file. 

6. Save the license file to your host PC, then return to the Welcome to Code Composer Studio 
window and under Step 2 - Install License File, browse to where you saved the license file. 
Click the OK button. 

7. You will then be presented with the Code Composer Studio Welcome screen. Click on the 
cube in the upper right-hand corner to go to the CCStudio workbench. 

 
8. The CCStudio workbench will then appear. 
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8.4 Run Sample Test 
As an example, we will run one feature test. In order to run a test program, you will have to select 
the program, compile (or build) the program, and then load the compiled program. The following 
steps will walk you through that process. 

1. From the menu bar, select Project > Import Existing CCS/CCE Eclipse Project. 

 
2. Browse to the location where you saved the BSL files on your host PC and down to the 

AM1808_BSL\src\bsl directory. Click the OK button. Verify the correct project exists in the 
Discovered projects: window and then click the Finish button. 
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3. Once again, select Project > Import Existing CCS/CCE Eclipse Project. This time browse 
to the tests folder, AM1808_BSL\src\tests. Click the OK button. Verify the correct project 
exists in the Discovered projects: window and then click the Finish button. 

 
4. In the Projects window on the left, expand the AM1808 BSL folder and verify the .ccxml file is 

set as Active/Default. If not, right-click on the .ccxml file name and select Set as Active 
Target Configuration, then repeat to also Set as Default Target Configuration. 
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5. Once again in the Projects window on the left, expand the AM1808eXp LED_DIP Test 
project. Right-click on the file name and select Set as Active Project. 

 
6. The test must now be compiled; from the CCStudio menu bar select Project > Build Active 

Project. 
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7. Once the Console window prints the message “Build Complete,” select Target > Debug 
Active Project from the menu bar. (NOTE: If you receive a message stating “Error 
connecting to the target,” press the reset button on the baseboard and then click Retry.) 

 
8. After the test finishes loading, you will see a message in the Console window stating 

“Memory Map Setup Complete.” 

 
9. To run the program, select Target > Run from the menu bar. (NOTE: If you receive a 

message stating “Error during: Execution, Initialization, Control,” click Cancel, select Target 
> Terminate All from the menu bar, press the reset button on the baseboard, and repeat 
steps 7-9.) 
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10. The Console window provides a brief description of the test. If you move any of the S2 DIP 
switches, output text will print the switch that was moved and its new position (ON or OFF) 
and USER LED1 or USER LED2 will turn on or off in relation to the DIP switch position. 

 
The steps in this section can be repeated to run any of the other tests for your EVM. (NOTE: All 
of the tests in the “experimenter” folder can be run on both the AM1808 EVM and eXperimenter 
Kit; the tests in the “evm” folder can only be run on the AM1808 EVM.) 
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Appendix A: Additional Documentation 

Software Documentation 
■ The Windows CE SD card included with your AM1808 EVM includes Software Developer 

Guides for Windows CE. Please see the setup.htm files on the SD card for information. 

■ U-Boot documentation  
http://www.denx.de/wiki/U-Boot/WebHome 

■ TI Code Composer Studio documentation  
http://focus.ti.com/dsp/docs/dspsupportatn.tsp?sectionId=3&tabId=415&familyId=44&toolTyp
eId=30  

Hardware Documentation 
All of the following links are also available on your “My Account” page on the Logic PD website 
(http://support.logicpd.com/auth/). 

■ Logic PD Zoom AM1808 EVM QuickStart Guide  
http://support.logicpd.com/downloads/1293/  

■ Logic PD Zoom AM1808 EVM Hardware Design Files (BOMs, Schematics, and Layout Files 
for all boards included in the EVM) 
http://support.logicpd.com/downloads/1396/  

■ Logic PD AM1808 SOM-M1 Hardware Specification 
http://support.logicpd.com/downloads/1324/  

http://www.denx.de/wiki/U-Boot/WebHome�
http://focus.ti.com/dsp/docs/dspsupportatn.tsp?sectionId=3&tabId=415&familyId=44&toolTypeId=30�
http://focus.ti.com/dsp/docs/dspsupportatn.tsp?sectionId=3&tabId=415&familyId=44&toolTypeId=30�
http://support.logicpd.com/auth/�
http://support.logicpd.com/downloads/1293/�
http://support.logicpd.com/downloads/1396/�
http://support.logicpd.com/downloads/1324/�
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