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1 Introduction 
This application note outlines how to install and use Code Composer Studio (CCS) v4.2.4 with the 
OMAP-L138 SOM-M1, TMS320C6748 (C6748) SOM-M1, and AM1808 SOM-M1 BSL files to test 
the functionality of the Zoom™ OMAP-L138 eXperimenter Kit, the Zoom OMAP-L138 EVM 
Development Kit, the Zoom AM1808 eXperimenter Kit, or the Zoom AM1808 EVM Development 
Kit. 

The Blackhawk XDS100v1 and Blackhawk XDS100v2 are the targeted emulators throughout this 
application note. If you would like to use a different emulator or need additional information on the 
Blackhawk XDS100v2, please visit the following Texas Instruments (TI) wiki articles: How to 
connect to EVM board using CCS1 and Emulation.2 

1.1 Nomenclature 
Throughout this application note, the term development kit refers to either the eXperimenter or the 
EVM Development Kit. Where a difference exists between the development kits, the specific name 
will be used. 

A test ending with eXp will run on both the eXperimenter Kits and the EVM Development Kits. A 
test ending with EVM will only run on the EVM Development Kits. 

ARM refers to a test that will run on the ARM core of the OMAP-L138 SOM-M1 or the AM1808 
SOM-M1. DSP refers to a test that will run on the DSP core of the OMAP-L138 SOM-M1 or the 
C6748 SOM-M1.   

1.2 Requirements 
This application note assumes the following: 

■ Your OMAP-L138 or AM1808 Development Kit is properly assembled as described in the 
appropriate QuickStart Guide. 

□ Zoom OMAP-L138 eXperimenter Kit QuickStart Guide3 
□ Zoom OMAP-L138 EVM QuickStart Guide4 
□ Zoom AM1808 eXperimenter Kit QuickStart Guide5 
□ Zoom AM1808 EVM QuickStart Guide6 with the User Interface (UI) board connected 

■ You are familiar with the User Guide associated with your development kit. 

□ Zoom OMAP-L138 eXperimenter Kit User Guide7 
□ Zoom OMAP-L138 EVM User Guide8 
□ Zoom AM1808 eXperimenter Kit User Guide9 
□ Zoom AM1808 EVM User Guide10 

                                                      
1 http://processors.wiki.ti.com/index.php/How_to_connect_to_the_OMAP-L138/C6748/AM1808_EVM_board_using_CCS%3F 
2 http://processors.wiki.ti.com/index.php/Category:Emulation 
3 http://support.logicpd.com/downloads/1367/  
4 http://support.logicpd.com/downloads/1230/  
5 http://support.logicpd.com/downloads/1294/ 
6 http://support.logicpd.com/downloads/1293/ 
7 http://support.logicpd.com/downloads/1363/  
8 http://support.logicpd.com/downloads/1214/  
9 http://support.logicpd.com/downloads/1424/ 
10 http://support.logicpd.com/downloads/1296/ 

http://processors.wiki.ti.com/index.php/How_to_connect_to_the_OMAP-L138/C6748/AM1808_EVM_board_using_CCS%3F
http://processors.wiki.ti.com/index.php/How_to_connect_to_the_OMAP-L138/C6748/AM1808_EVM_board_using_CCS%3F
http://processors.wiki.ti.com/index.php/Category:Emulation
http://support.logicpd.com/downloads/1367/
http://support.logicpd.com/downloads/1230/
http://support.logicpd.com/downloads/1294/
http://support.logicpd.com/downloads/1293/
http://support.logicpd.com/downloads/1363/
http://support.logicpd.com/downloads/1214/
http://support.logicpd.com/downloads/1424/
http://support.logicpd.com/downloads/1296/
http://processors.wiki.ti.com/index.php/How_to_connect_to_the_OMAP-L138/C6748/AM1808_EVM_board_using_CCS%3F
http://processors.wiki.ti.com/index.php/Category:Emulation
http://support.logicpd.com/downloads/1367/
http://support.logicpd.com/downloads/1230/
http://support.logicpd.com/downloads/1294/
http://support.logicpd.com/downloads/1293/
http://support.logicpd.com/downloads/1363/
http://support.logicpd.com/downloads/1214/
http://support.logicpd.com/downloads/1424/
http://support.logicpd.com/downloads/1296/
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■ You have the Blackhawk XDS100v2 model D USB JTAG controller11 that was included with 
your development kit (see Figure 1.1). IMPORTANT NOTE: Do not attach the Blackhawk 
XDS100v2 until CCS v4.2 has been installed on your host PC. 

 

 

 

 

 
 

Figure 1.1: Blackhawk XDS100v2 with JTAG adapter 

Your Blackhawk XDS100v2 must have the latest firmware. For information on how to update 
to the latest firmware, please refer to TI’s wiki article How Can I Update the CPLD on My 
XDS100v2.12 

■ Your host PC has an available USB port and active internet connection. 

2 Setup 
This section explains how to install and set up CCS v4.2.4 to run the BSL tests on your OMAP-
L138 SOM-M1, C6748 SOM-M1, or AM1808 SOM-M1. Differences between setting up Blackhawk 
XDS100v1 and Blackhawk XDS100v2 on the development kit will also be addressed within the 
setup provided below. 

The projects in this workspace have been tested in CCS v4.2.4. If you are not using CCS v4.2.4, 
you may be given a warning that the workspace was created with a previous version of CCS; click 
OK and continue. 

 

2.1 Installing CCS v4.2.4 
Install CCS v4.2.4 if it is not already installed on your host PC. This TI wiki article13 provides 
information for properly installing the software.  

Again, this application note was tested on and written specifically for CCS v4.2.4. 

NOTE: Once you have downloaded CCS v4.2.4, there is a bug that must be fixed if you wish to 
make your own target configuration .ccxml files: 

1. Go to directory <CCS_INSTALL_DIR>/ccsv4/common/targetdb/Devices. 
                                                      
11 http://www.blackhawk-dsp.com/products/USB100.aspx  
12 http://processors.wiki.ti.com/index.php/XDS100#Q:_How_can_I_update_the_CPLD_on_my_XDS100v2.3F 
13 http://processors.wiki.ti.com/index.php/Code_Composer_Studio_v4 

http://www.blackhawk-dsp.com/products/USB100.aspx
http://processors.wiki.ti.com/index.php/XDS100#Q:_How_can_I_update_the_CPLD_on_my_XDS100v2.3F
http://processors.wiki.ti.com/index.php/XDS100#Q:_How_can_I_update_the_CPLD_on_my_XDS100v2.3F
http://processors.wiki.ti.com/index.php/Code_Composer_Studio_v4
http://www.blackhawk-dsp.com/products/USB100.aspx
http://processors.wiki.ti.com/index.php/XDS100#Q:_How_can_I_update_the_CPLD_on_my_XDS100v2.3F
http://processors.wiki.ti.com/index.php/Code_Composer_Studio_v4
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2. Open the device file being used in a text editor. 

3. In the second line, inside the directive <device>, replace the parameter desc with description. 

4. Save the file and restart CCS. 

2.2 Setting Up the Workspace 

1. Download the OMAP-L138/TMS320C6748/AM1808 SOM-M1 Gel, CCS Setup, and BSL Files 
(CCS v4.2.4)14 from the Logic PD website. (You can also access this download under the 
Software Development Tools section of your development kit’s downloads page.) 

2. Extract the files to a new folder on your C: Drive. For the purposes of this application note, the 
folder has been named CCS4. 

3. Launch CCS v4.2.4 by selecting Start > All Programs > Texas Instruments > Code Composer 
Studio v4.x.x > Code Composer Studio v4. 

4. When asked to choose your workspace folder, browse to the location you extracted the files 
(e.g., C:\ccs4\CCSv4-2-4_with_SOM-M1_BSL_WS). 

 
NOTE: If you would like to switch to a different workspace once you are in CCS v4.2, select 
File > Switch Workspace > Browse > C:\[Your Workspace]. 

                                                      
14 http://support.logicpd.com/downloads/1433/  

http://support.logicpd.com/downloads/1433/
http://support.logicpd.com/downloads/1433/
http://support.logicpd.com/downloads/1433/
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2.3 Setting Up the Development Kit 

2.3.1 Blackhawk XDS100v1 

1. Connect the following components of your development kit as documented in the online 
QuickStart Guide. Wait to switch on the power. 

□ Zoom OMAP-L138 eXperimenter Kit QuickStart Guide 
□ Zoom OMAP-L138 EVM QuickStart Guide 
□ Zoom AM1808 eXperimenter Kit QuickStart Guide 
□ Zoom AM1808 EVM QuickStart Guide 

2. Using the USB cable provided, connect the Emulation USB port to the USB port on your PC. 

 
Figure 2.1: Connection to Emulation USB Port 

3. EVM DELOPEMENT KITS ONLY: Carefully connect the UI Board to J28 and J29 on the 
baseboard. 

4. On the baseboard, set DIP switches S7:5 and S7:8 to ON and all other switches to OFF (see 
Figure 2.2). 

5. Power on your development kit as documented in the QuickStart Guide. NOTE: The 
Blackhawk XDS100v1 emulator is not supported on the ARM core. 

2.3.2 Blackhawk XDS100v2 

1. Connect the Blackhawk XDS100v2 JTAG Controller to J23 on the baseboard. (Please refer to 
your development kit’s User Guide for detailed instructions on connecting the Blackhawk 
XDS100v2.) 

2. EVM DELOPEMENT KITS ONLY: Verify the UI Board is connected to J28 and J29 on the 
baseboard. 

3. On the baseboard, set DIP switches S7:5 and S7:8 to ON and all other switches to OFF (see 
Figure 2.2). 

4. Power on your development kit as documented in the QuickStart Guide.  
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Figure 2.2: S2 & S7 DIP Switch Required Settings 

2.4 Sample Tests 
This section will discuss how to run a sample project in CCS v4.2.4. 

NOTE: 

■ The Blackhawk XDS100v1 emulator does not support the ARM core. 

■ When switching from Blackhawk XDS100v2 to Blackhawk XDS100v1, you must completely 
remove the Blackhawk USB100v2 from the baseboard connectors and restart CCS v4.2. This 
is not necessary when switching from Blackhawk XDS100v1 to Blackhawk XDS100v2. 

■ When switching BSLs, remember to change both the active and default projects and .ccxml 
files. 

■ Run all tests in debug mode, not release mode. 

■ Use instructions in Section 2.4.2 if you are running a sample project with the following setup: 
DSP core with ARM slave on the OMAP-L138 with Blackhawk XDS100v2. Use instructions in 
Section 2.4.1 for all other setups. 

Below is a table explaining which tests can be run on which platforms and which debuggers are 
applicable: v1 indicates the test uses the Blackhawk XDS100v1; v2 indicates the test uses the 
Blackhawk XDS100v2. If a debugger is not listed, that particular project is not supported to run on 
that setup. The eXperimenter Kit is labeled eXp and the EVM Development Kit is labeled EVM. 

Table 2.1: Supported Debuggers and Projects 

Project 
C6748  

eXp 
C6748  
EVM 

OMAP-L138 
eXp 

OMAP-L138  
EVM 

AM1808 
eXp 

AM1808  
EVM 

ARM_EVM Character LCD Test 
   

v2 
 

v2 

ARM_EVM Composite Video Test 
   

v2 
 

v2 

ARM_EVM Emac Loopback RMII Test 
   

v2 
 

v2 

ARM_EVM Image Sensor Test 
   

v2 
 

v2 

ARM_EVM LED and Pushbutton Test 
   

v2 
 

v2 

ARM_EVM NAND Test 
   

v2 
 

v2 

ARM_EVM NOR Test 
   

v2 
 

v2 

ARM_EVM S-Video Test 
   

v2 
 

v2 

ARM_EVM UPP Test 
   

v2 
 

v2 

ARM_eXp Audio Test 
  

v2 v2 v2 v2 
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Project 
C6748  

eXp 
C6748  
EVM 

OMAP-L138 
eXp 

OMAP-L138  
EVM 

AM1808 
eXp 

AM1808  
EVM 

ARM_eXp Emac Loopback MII Test 
  

v2 v2 v2 v2 

ARM_eXp Graphics LCD Test   v2 v2 v2 v2 

ARM_eXp lCD Touch Test 
  

v2 v2 v2 v2 

ARM_eXp LED_DIP Test 
  

v2 v2 v2 v2 

ARM_eXp MMCSD Test 
  

v2 v2 v2 v2 

ARM_eXp PMIC Test 
  

v2 v2 v2 v2 

ARM_eXp Ram Test 
  

v2 v2 v2 v2 

ARM_eXp Read Mac Test 
  

v2 v2 v2 v2 

ARM_eXp RTC Test 
  

v2 v2 v2 v2 

ARM_eXp SATA Test 
  

v2 v2 v2 v2 

ARM_eXp SPI Flash Test 
  

v2 v2 v2 v2 

ARM_eXp UART Test 
  

v2 v2 v2 v2 

ARM_eXp USB Test 
  

v2 v2 v2 v2 

DSP_EVM C-Video Test  
 

v1/v2 
 

v1/v2 
  DSP_EVM Emac Loopback RMII Test 

 
v1/v2 

 
v1/v2 

  DSP_EVM Image Sensor Test 
 

v1/v2 
 

v1/v2 
  DSP_EVM LCD Char Test 

 
v1/v2 

 
v1/v2 

  DSP_EVM LED PB Test 
 

v1/v2 
 

v1/v2 
  DSP_EVM NAND Test 

 
v1/v2 

 
v1/v2 

  DSP_EVM NOR Test 
 

v1/v2 
 

v1/v2 
  DSP_EVM S-Video Test 

 
v1/v2 

 
v1/v2 

  DSP_eXp Audio Test v1/v2 v1/v2 v1/v2 v1/v2 
  DSP_eXp Emac Loopback MII Test v1/v2 v1/v2 v1/v2 v1/v2 
  DSP_eXp LCD Graphics Test v1/v2 v1/v2 v1/v2 v1/v2 
  DSP_eXp LCD Touch Test v1/v2 v1/v2 v1/v2 v1/v2 
  DSP_eXp LED DIP Test v1/v2 v1/v2 v1/v2 v1/v2 
  DSP_eXp MMCSD Test v1/v2 v1/v2 v1/v2 v1/v2 
  DSP_eXp PMIC Test v1/v2 v1/v2 v1/v2 v1/v2 
  DSP_eXp RAM Test v1/v2 v1/v2 v1/v2 v1/v2 
  DSP_eXp Read Mac Test v1/v2 v1/v2 v1/v2 v1/v2 
  DSP_eXp RTC Test v1/v2 v1/v2 v1/v2 v1/v2 
  DSP_eXp SATA Test v1/v2 v1/v2 v1/v2 v1/v2 
  DSP_eXp SPI Flash Test v1/v2 v1/v2 v1/v2 v1/v2 
  DSP_eXp UART Test v1/v2 v1/v2 v1/v2 v1/v2 
  DSP_eXp UPP Test v1/v2 v1/v2 v1/v2 v1/v2 
  DSP_eXp USB Test v1/v2 v1/v2 v1/v2 v1/v2 
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2.4.1 Running a Sample Test 

Now we will run a sample test to show how the test procedure works. 

1. In the CCS v4.2.4 application, verify the correct emulation configuration is set as 
active/default. 

NOTE: The OMAPL138_XDS100v2.ccxml and the AM1808_XDS100v2.ccxml files are located 
in the ARM BSL folder. All other .ccxml files referred to are located in the DSP BSL folder. 

□ For using the ARM core on the OMAP-L138 with Blackhawk XDS100v2, set 
OMAPL138_XDS100v2.ccxml as active/default in the ARM BSL folder. 

□ For using the DSP core on the OMAP-L138 with Blackhawk XDS100v1, set 
OMAPL138_XDS100v1.ccxml as active/default in the DSP BSL folder. 

□ For using the DSP core with the ARM slave on the OMAP-L138 with Blackhawk 
XDS100v2, set OMAPL138_XDS100v2.ccxml as active/default in the ARM BSL folder. 

□ For using the C6748 with Blackhawk XDS100v1, set C6748_XDS100v1.ccxml as 
active/default in the DSP BSL folder. 

□ For using the C6748 with Blackhawk XDS100v2, set C6748_XDS100v2.ccxml as 
active/default in the DSP BSL folder. 

□ For using the AM1808 with Blackhawk XDS100v2, set AM1808_XDS100v2.ccxml as 
active/default in the ARM BSL folder. 

For example, to set the AM1808 with Blackhawk XDS100v2 as active/default target 
configuration, select View > C/C++ from the menu toolbar.  

a. In the C/C++ Projects window, expand the ARM BSL folder.  

b. Right click on the AM1808_XDS100v2.ccxml file and select Set as Default Target 
Configuration. 

 
 

c. Next, right-click AM1808_XDS100v2.ccxml again, but now select Set as Active Target 
Configuration. 
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2. Right click the ARM eXp LCD Touch Test folder and select Set as Active Project. 

 
 

3. To start debugging, select Target > Debug Active Project from the menu toolbar. CCS v4.2.4 
will begin to access your target through the Blackhawk USB100v2 JTAG Controller or the 
Emulator Port. 

Your development kit is now available for debugging.  

4. To run the selected project, select Target > Run or press F8. 

5. You should now see the console being loaded with test description information. Follow the 
instructions to complete the test. 

For this specific test, a set of crosshairs will appear anywhere you touch the touch-screen 
display. 

6. You can repeat these steps to run any of the tests included in the BSL, but be sure to closely 
follow the directions printed to the console. 

7. To stop a test from running, select Target > Terminate All. 

2.4.2 Running a Sample Test on OMAP-L138 Using DSP Core with Blackhawk XDS100v2 

This approach will need to be taken when using the DSP core with ARM slave on the OMAP-L138 
SOM-M1 with Blackhawk XDS100v2 because both the DSP and ARM cores need to be active (or 
“woken up”). 

Now we will run a sample test to show how the test procedure works. 
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1. Select View > Target Configurations. 

 

2. Right-click on the desired target and select Launch Selected Configuration. 
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3. Once the debugger is launched, right-click on the ARM core and select Connect Target. 

 

4. Right-click on the DSP core and select Connect Target. 

5. Load the program to the target by selecting Target > Load Program... 

NOTE: When loading the program, you must have the DSP selected. You do this by left-
clicking on the “0 <symbol…” below the Thread of the DSP (see Figure 2.3). After selecting 
Target > Load Program… with the DSP selected, select Browse Project and pick the project 
you want to build. From this point on, run the project normally by selecting Target > Run. 

 
Figure 2.3: Selecting the DSP Core 
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2.5 Troubleshooting 
If you experience difficulty getting any test to run, here are some troubleshooting actions you can 
take: 

1. Consider cycling the power on your development kit, especially if there were recent changes 
to the CCXML settings. 

2. Make sure that the test is in debug mode, not release mode by right-clicking [Your Project] and 
then selecting Active Build Configuration > Debug. 

3. Review the Debugging JTAG Connectivity Problems15 wiki article. 

4. Make sure you have updated the CPLD firmware on your Blackhawk XDS100v2.16 

5. If you are using the Blackhawk XDS100v2, XDS510, or XDS560 emulators, review the 
connection instructions in this TI wiki article17 to verify your setup. 

6. Search for specific articles on the TI wiki web page18 pertaining to the problem you are 
experiencing. 

3 Requirements, Summary and Known Issues of Tests 
Below is a summary of all the available tests in the CCS 4.x work space, including setup 
procedures, additional required equipment, and expected outputs. 

Items specified in the requirements list identify additional equipment that is required beyond that 
which is included in the development kit.  

Each test has a CCS console.txt log file created and stored in the associated directory within \ 
CCSv4-2-4_with_SOM-M1_BSL_WS \ \test_results. This log file shows the expected output from 
the CCS console window when a test is passed.  

3.1 eXperimenter and EVM Development Kit Tests 
The following tests can be run on the eXperimenter or EVM Development Kits. 

3.1.1 ARM/DSP eXp Audio Test 

This test will begin by playing a five-second tone through the line-out port. The 3.5mm 
pass-through cable will not be required for this portion of the test. After playing the tone, audio 
from the line-in port will be played through the line-out port for fifteen seconds.  

In order to complete this test and check the results, you must have headphones plugged into the 
audio line-out port on the baseboard throughout the testing procedure. After the first test has 
completed and the five-second tone has ended, insert an audio source into the line-in port and 
check that the source is being mirrored through the headphones.  

■ Requirements:  

□ 3.5mm pass-through cable 
□ 3.5mm headphones 

                                                      
15 http://processors.wiki.ti.com/index.php/Debugging_JTAG_Connectivity_Problems 
16 http://processors.wiki.ti.com/index.php/XDS100#Q:_How_can_I_update_the_CPLD_on_my_XDS100v2.3F 
17 http://processors.wiki.ti.com/index.php/How_to_connect_to_the_OMAP-
L138/C6748_EVM_board_using_CCS%3F#XDS100v2.2C_XDS510_or_XDS560_external_emulator_-_DSP_.2B_ARM_.28OMAP-
L138_SOM.29 
18 http://processors.wiki.ti.com/index.php/Main_Page 
 

http://processors.wiki.ti.com/index.php/Debugging_JTAG_Connectivity_Problems
http://processors.wiki.ti.com/index.php/XDS100#Q:_How_can_I_update_the_CPLD_on_my_XDS100v2.3F
http://processors.wiki.ti.com/index.php/How_to_connect_to_the_OMAP-L138/C6748_EVM_board_using_CCS%3F#XDS100v2.2C_XDS510_or_XDS560_external_emulator_-_DSP_.2B_ARM_.28OMAP-L138_SOM.29
http://processors.wiki.ti.com/index.php/Main_Page
http://processors.wiki.ti.com/index.php/Debugging_JTAG_Connectivity_Problems
http://processors.wiki.ti.com/index.php/XDS100#Q:_How_can_I_update_the_CPLD_on_my_XDS100v2.3F
http://processors.wiki.ti.com/index.php/How_to_connect_to_the_OMAP-L138/C6748_EVM_board_using_CCS%3F#XDS100v2.2C_XDS510_or_XDS560_external_emulator_-_DSP_.2B_ARM_.28OMAP-L138_SOM.29
http://processors.wiki.ti.com/index.php/How_to_connect_to_the_OMAP-L138/C6748_EVM_board_using_CCS%3F#XDS100v2.2C_XDS510_or_XDS560_external_emulator_-_DSP_.2B_ARM_.28OMAP-L138_SOM.29
http://processors.wiki.ti.com/index.php/How_to_connect_to_the_OMAP-L138/C6748_EVM_board_using_CCS%3F#XDS100v2.2C_XDS510_or_XDS560_external_emulator_-_DSP_.2B_ARM_.28OMAP-L138_SOM.29
http://processors.wiki.ti.com/index.php/Main_Page
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■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 

3.1.2 ARM/DSP eXp Emac MII Loopback Test 

The test will begin by initializing the Ethernet PHY on the eXperimenter or EVM baseboard. After 
initializing, the PHY Activity / Link lights should be illuminated. The PHY will then be placed in 
loopback mode and a packet will be transmitted. The packet will be checked against the original 
data after it is received. Note that a loopback cable is not required. 

■ Requirements: None 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 

3.1.3 ARM/DSP eXp Graphics LCD Test 

This code will configure the LCD controller to interface with a 4.3” Logic PD Display Kit. Once 
configured, a test pattern will be displayed on the LCD. 

■ Requirements: None 

■ Visible Output: See the CCS console.txt log file. Figure 3.1 shows the test pattern seen when 
running the graphics LCD Test. 

■ Known Issues: None 

 
Figure 3.1: Graphics LCD Test Image 

3.1.4 ARM/DSP eXp LCD Touch Test 

This code will configure the LCD controller to interface with a Logic PD Display Kit and the PMIC 
to output touch interrupts. Once configured, the LCD will be wiped clean and the code will loop 
reading touch axes and updating crosshairs drawn on the LCD. 

■ Requirements: None 

■ Visible Output: See the CCS console.txt log file 
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■ Known Issues:  

□ Workaround : Terminate the test and submit Debug Active Project 

 
Figure 3.2: LCD Touch Test Image 

3.1.5 ARM/DSP eXp LED & DIP test 

This code will begin by flashing the LEDs and then sit in a forever-loop checking the S2 DIP 
switches. When a change in the DIP switches is detected, a message will be printed to stdout and 
an LED will be toggled. 

For instance, if you move DIP switch S2:4 to the ON position and then OFF, and then move DIP 
switch S2:5 to the ON position and then OFF, you can expect the console to be output the 
following: 

DIP switch[4] was switched on 
DIP switch[4] was switched off 
DIP switch[5] was switched on 
DIP switch[5] was switched off 
--------------------------------------------------------------------- 

USER LED1 and USER LED2 are used in this test to signify that the DIP switches have changed 
position. Moving DIP switches S2:1-4 will cause USER LED2 to illuminate, whereas moving DIP 
switches S2:5-9 will cause USER LED1 to illuminate. 

■ Requirements: None 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 

3.1.6 ARM/DSP eXp MMCSD Test 

This code will read/write data to an SD card inserted into the slot located on the bottom side of the 
board below the audio jacks. 

■ Requirements: SD card inserted into J14 of the baseboard. SDHC or MMC is not currently 
supported. 
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■ Visible Output: See the CCS console.txt log file 

■ Known Issues: The test is not supported for the DSP core on the OMAP-L138 with Blackhawk 
XDS100v1, the ARM core on the OMAP-L138 with Blackhawk XDS100v2, or on the AM1808 
with Blackhawk XDS100v2. If this test fails with a different setting, try using a different SD 
card.  

3.1.7 ARM/DSP eXp PMIC Test 

This test demonstrates the operation of the OMAP-L138, C6748, or AM1808 I/O at 1.8V. The 
OMAP-L138, C6748, or AM1808 will read the contents of the PMIC control registers and display 
them. The OMAP-L138, C6748, or AM1808 will also adjust its system clock frequency for 
additional power savings. The user should flip the 3.3V/1.8V DIP switch (S7:3) to the ON position 
prior to executing this test for 1.8V. 

■ Requirements: None 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 

3.1.8 ARM/DSP eXp RAM Test 

This code verifies the mDDR address bus and writes/verifies data patterns to the mDDR. This test 
takes approximately ninety seconds to complete. 

■ Requirements: None 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 

3.1.9 ARM/DSP eXp Read MAC Test 

This code reads and prints the Media Access Control (MAC) address that was written into 
SPI flash. 

■ Requirements: None 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 

3.1.10 ARM/DSP eXp RTC Test 

This code will configure the RTC module, set the time, and verify the time is correct after ten 
seconds. 

■ Requirements: None 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 

3.1.11 ARM/DSP eXp SATA Test  

This test will check for the connection of a SATA disk drive and attempt to spin-up the disk drive. If 
the connection is not detected or the spin-up is not completed, the test will fail. 

■ Requirements: An externally-powered SATA disk drive will need to be connected to J32 of the 
baseboard before the test begins. 

□ SATA disk drive 
□ SATA cable 
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□ SATA external power source 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 

3.1.12 ARM/DSP eXp SPI Flash Test 

This code will configure the SPI to interface with the flash on the OMAP-L138, C6748, or AM1808 
SOM-M1. Once configured, the code will read and write a portion of SPI flash.  

IMPORTANT NOTE: This test takes approximately ninety seconds to complete and will modify 
(i.e., erase) the memory contents in SPI flash. 

■ Requirements: None 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 

3.1.13 ARM/DSP eXp UART Test 

This code will configure the UART and use a microsecond timer to count to ten, printing each 
second. Note that the timer column (the second column from the UART terminal) will vary from 
machine to machine. 

■ Requirements: RS232 serial cable connected to a host computer running a terminal emulator 
configured for 115200 baud, 8-bit, no parity, 1 stop bit, no flow control and P1 of the 
baseboard. 

■ Visible Output: See the CCS console.txt log file and uart_terminal.txt file for expected output in 
the terminal emulator 

■ Known Issues: None 

3.1.14 ARM/DSP eXp USB Test 

This test will reproduce the given console output. First, make sure nothing is connected to the USB 
OTG or host USB ports. After the first test is completed, use the USB A-to-mini B cable to connect 
the host USB port (J27) to the USB OTG port (J6). 

■ Requirements: USB A-to-mini B cable 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 
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3.2 EVM Development Kit Tests Only 
The following tests can only be run on the EVM Development Kits. The UI board must be attached 
to run these tests. Remove power from the kit when changing the board configuration. 

3.2.1 ARM/DSP EVM Character LCD Test 

This code scrolls a message across the character LCD on the UI board. Be sure the potentiometer 
between the display and the pushbuttons is set to appropriately control the backlight.  

■ Requirements: None 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 

 
Figure 3.3: Character LCD Test Display Image 

3.2.2 ARM/DSP EVM Composite Video Test 

This test will transmit video using a composite video connection. Connect a video output device 
(e.g., DVD player) to connector J6 and a video input device (e.g., TV) to connector J4. Start the 
video output device and execute the code. The video from the output device will be transmitted to 
the input device. 

■ Requirements:  

□ video output device (DVD player) 
□ video input device (TV) 
□ 2 composite video cables 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 

3.2.3 ARM/DSP EVM Emac RMII Loopback Test 

The test will begin by initializing the Ethernet PHY on the UI board. After initializing, the PHY 
Activity / Link lights should be illuminated. Then the PHY will be placed in loopback mode and a 
packet will be transmitted. The packet will be checked against the original data after it is received. 
Note that a loopback cable is not required for this test. 
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■ Requirements: None 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 

3.2.4 ARM/DSP EVM Image Sensor Test 

Image sensor was not available at the time of creating this application note. 

This code will configure an MT9V032 image sensor to output test data on the VPIF data bus and 
configure the VPIF for raw-capture receive mode. The code should be paused after each test 
pattern to allow the user to verify the data in memory. 

■ Requirements: Aptina MT9V032 Head Board 

■ Visible Output: Not available 

■ Known Issues: None 

3.2.5 ARM/DSP EVM LED and Pushbutton Test 

This code will begin by flashing the LEDs and then sit in a forever loop checking the pushbuttons. 
When a change in the pushbuttons is detected, a message will be printed to stdout and an LED 
will be toggled. 

NOTE: For this test, the button mapping is as follows: 

S3(baseboard) = Pushbutton[1] 
S1(expansion board) = Pushbutton[2] 
S2(expansion board) = Pushbutton[3] 
S3(expansion board) = Pushbutton[4] 
S4(expansion board) = Pushbutton[5] 
S5(expansion board) = Pushbutton[6] 
S6(expansion board) = Pushbutton[7] 
S7(expansion board) = Pushbutton[8] 
S8(expansion board) = Pushbutton[9] 
--------------------------------------------------------------------------- 

For a given input pattern of pressing and releasing Pushbutton[2] and then Pushbutton[3] during 
this test, you can expect the console to output the following: 

Pushbutton[2] was pressed 
Pushbutton[2] was released 
Pushbutton[3] was pressed 
Pushbutton[3] was released 
-------------------------------------------------------------------------- 

USER LED1 and USER LED2 are used to signify if a button has been pressed. Pressing 
Pushbutton[1-5] will cause USER LED2 to illuminate, whereas Pushbutton[6-9] will cause USER 
LED1 to illuminate. 

■ Requirements: None 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 

3.2.6 ARM/DSP EVM NAND Test 

This code will configure the EMIFA to interface with NAND flash on the UI board. Once configured, 
the code will read and write a block of the NAND flash. 



AN 492 Using CCS v4.2.4 with OMAPL138, C6748, and AM1808 SOM-M1 

PN 1020208B Logic PD, Inc. All Rights Reserved. 18 

■ Requirements: None 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 

3.2.7 ARM/DSP EVM NOR Test 

This code will configure the EMIFA to interface with NOR flash on the UI board. Once configured, 
the code will read and write a portion of NOR. 

■ Requirements: None 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 

3.2.8 ARM/DSP EVM S-Video Test 

For this test you need to connect a video output device (e.g., DVD player) to connector J5 and a 
video input device (e.g., TV) to connector J3. Start the video output device and execute the code. 
The video from the output device will be transmitted to the input device. 

■ Requirements:  

□ video output device (DVD player) 
□ video input device (TV) 
□ 2 s-video cables 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 

3.2.9 ARM/DSP EVM UPP Test 

The test will begin producing a 73.2421875 KHz sine wave on the analog-out line (left SMA 
connector). After twenty seconds, sixty-four samples will be collected from the ADC (right SMA 
connector). These samples will be output through the DAC for a period of twenty seconds.  

NOTE: The DAC and ADC are inductively/capacitively coupled with their connectors. It is strongly 
recommended that the signal provided to the ADC have a frequency that is an integer multiple of 
73.2421875 KHz and below 1.171875 MHz. 

■ Requirements:  

□ oscilloscope 
□ cable with SMA connector 
□ function generator (pass-through test only) 
□ second cable with SMA connector (pass-through test only) 

■ Visible Output: See the CCS console.txt log file 

■ Known Issues: None 



AN 492 Using CCS v4.2.4 with OMAPL138, C6748, and AM1808 SOM-M1 

PN 1020208B Logic PD, Inc. All Rights Reserved. 19 

 
Figure 3.4: UPP Test DAC Out to Oscilloscope Image 

 
Figure 3.5: UPP Test ADC in Samples Collected and Displayed with the Oscilloscope Image 
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4 Summary 
This application note outlined how to install and use CCS v4.2.4 with three separate modules, 
namely the OMAP-L138 SOM-M1, the TMS320C6748 SOM-M1, and the AM1808 SOM-M1. Each 
of these modules has a corresponding eXperimenter and EVM Development Kit that can be tested 
with its specific projects described in Section 2 and 3. The Blackhawk XDS100v1 and Blackhawk 
XDS100v2 were the targeted emulators throughout the application note. 

The source code for each of these tests is a good example to use as a starting point for the 
development of applications. The source, header, and included file lists can be found in each of 
the test projects included in this workspace example. 
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