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1 Introduction

This User Guide continues where the QuickStart Guide documentation ended by providing
additional hardware details about the Zoom OMAP-L138 eXperimenter Kit, as well as introductory
instructions for using Code Composer Studio and the included Board Support Library (BSL) files.

1.1 Scope of Document

m This User Guide references specific connectors on the application baseboard. However, the
discussion is limited to special use instructions; detailed information about the connectors
should be referenced on the respective schematic and Bill of Material (BOM) documents. See
Appendix A for links to these documents.

m This User Guide does not provide detailed instructions for the software included with the
eXperimenter Kit. Please refer to the specific User Guides for each respective software
product for additional information. A list of additional documentation is available in Appendix
A.

1.2 Requirements

m Itis assumed that the QuickStart Guide has been read in its entirety. See Appendix A for a
link to the QuickStart Guide.

m A host PC with CD/DVD drive, USB port, and at least 2 GB of hard drive space.
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Application Baseboard

Application Baseboard Features Diagram
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Application Baseboard Ethernet Jack

The Ethernet jack located on the application baseboard is to only be used with the MIl PHY;
whereas the Ethernet jack located on the Ul board is to be used only with the RMII PHY. The
Ethernet controller on the CPU can only talk to one Ethernet PHY at a time. Which Ethernet PHY
is being used is entirely controlled through software.

DIP Switches

There are two 8-position DIP switches located on the application baseboard at reference
designators S2 and S7. By default, all of the switches are set to the “OFF” position.
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The S2 DIP switch is reserved for user application general purpose. The S7 DIP switch controls
the processor’s boot mode and several FET muxes on the baseboard. Table 2.1 describes the
function of each switch.

Table 2.1: S7 DIP Switch Functions

Switch | OFF Position ON Position

S7:1* Baseboard LCD drive enabled. Baseboard LCD drive disabled.
Baseboard audio enabled. Associated | Baseboard audio disabled.
MCcASP lines connect to baseboard Associated McASP lines are available

S7:2 audio only. on audio expansion connector.

S7:3 OMAP-L138 I/O runs at 3.3V OMAP-L138 I/O runs at 1.8V

S7:4 No connection

S7:5 BOOT[1]

S7:6 BOOT[2]

S7:.7 BOOT[3]

S7:8 BOOT[4]

*Note: S7:1 indicates slide 1 on the S7 DIP switch, S7:2 indicates slide 2 on
the S7 DIP switch, and so on.

A default boot mode has been defined by pulling all boot pins (BOOT[0:7]) to a default state on
the SOM. The default boot mode is SPI1 Flash; all available boot modes are described in Table
2.2.

Table 2.2: S7 DIP Switch Boot Modes

DIP Switch Setting—S7[5:8]
BOOT[4] |BOOT[3] [BOOT[2] |BOOTI[1]

Boot Mode S7:8 S7:7 S7:6 S7:5
NOR EMIFA OFF ON ON ON
NAND-8 EMIFA | OFF OFF OFF ON

Default | SPI1 Flash OFF OFF OFF OFF
UART2 ON ON OFF OFF
EMU Debug ON OFF OFF ON

3 Installing Code Composer Studio

The Zoom OMAP-L138 eXperimenter Kit includes a software DVD containing Code Composer
Studio (CCStudio).
1. Insert the Code Composer Studio v4 software DVD into your host PC.

2. Navigate to the DVD drive and open the files on the CCStudio DVD. Double-click on
setup_CCS _4.2.x.xxxxx.exe and a splash screen similar to the image below will appear. Click
the Next button.
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Code Composer Studio v4 Setup E

Welcome to the Code Composer
Studio v4 Installation Wizard

This will install Code Composer Studio v4
on your computer.

It is recommended that you dose all other
applications before continuing.

Click Next to continue or Cancel to exit
Setup.

[ MNext > |I Cancel I

Follow the on screen instructions until you arrive at the screen for Product Configuration,
select Platinum Edition.

On the next screen, leave the default ISA items checked. Click the Next button.
Click the Next button to start copying files.
Wait for CCStudio to finish installing; this process can take some time, so please be patient.

Click the Finish button when the installation is complete. You may eject the CCStudio DVD
at this time.

Running Board Support Library (BSL) Sample Programs

The BSL sample programs are included to test the different features of the development kit and
diagnose any potential problems. In order to run these tests, you first have to connect your
development kit to a PC.

Copy BSL Files to PC

Both SD cards included with the OMAP-L138 eXperimenter Kit contain the GEL and BSL files.
These files need to be copied to your host PC.

1.
2.

Navigate into the SD card and locate the BSL directory.

Extract the ZIP archive and save the files to your host PC. (NOTE: The files may be placed
anywhere on your host PC; however, the original file structure must remain intact.)

For the instructions in this User Guide, it is assumed the files were copied to the root C:\
drive. For example:

C:\OMAP-L138_GEL_BSL_Files_v2.3
C:\TMS320C6748_GEL_BSL_Files_v2.3

Connect eXperimenter Kit to Host PC

To communicate with the OMAP-L138 eXperimenter Kit using CCStudio, you will need to connect
the included USB A to mini-B cable to the USB emulator port on the application baseboard and
your host PC.
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As soon as the USB cable connects to your host PC, Windows should automatically recognize
that new hardware has been connected and install the necessary drivers. Power on your
OMAP-L138 eXperimenter Kit and continue with the next section.

4.3 Launch Code Composer Studio

1. Launch Code Composer Studio by selecting Start Menu > All Programs > Texas
Instruments > Code Composer Studio v4.2.0 > Code Composer Studio v4.

2. Select a workspace location and then click the OK button.

@ Workspace Launcher

Select a workspace

Code Composer Studio stores your projects in a folder called a workspace.
Choose a workspace folder to use for this session.

Workspace: |C:"-.CCS_w-:-rkspace v| [ Browse...

[] Use this as the default and do not ask again

[ ok [ canca |

3. CCStudio will finish launching and a Welcome to Code Composer Studio window will open.
(NOTE: If you do not have the latest Adobe Flash Player installed on your machine, you will

be prompted to install. This is required for proper viewing of the Code Composer Studio
Welcome screen.)

4. If you do not have a license, select the Activate a License option and click the Use Free
Limited License button. (NOTE: If you do not have an active Internet connection, you can
select to Evaluate Code Composer Studio for 30 days. At any time during that period, you
can change to the Free Limited License by selecting Help > License Options... from the
CCStudio menu bar and then following the onscreen instructions.)
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'@ Welcome to Code Composer Studio E

Mo valid licenze for Code Composer Studio could be found.

(") Evaluate Code Composer Studio for 30 days
(®) Activate a Licenze

Step 1 - Generate Licenze File
MHate: [f wou already have a licenze file, skip to the nest step.

Pleaze note that pou will need to use one of the following Host 1Dz duning the registration process:;
24 2b2bSf0es7

[ Reqgister ] Reqizter online uging an activation code.

Click to actieate a free licenze that enables pou to work with #05700 emulators,
I1ze Free Limited Licenze [ zsimulators and emulators integrated onto standard BN /DSK /22D 5P development boardz.
Do not uge thiz license for MSP430,

Step 2 - Inztall Licenze File

(%) Specify a licenze file
| | [ Browse. .. ]

() Specify a license server

) Cancel
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You will be redirected to TI's website to login in with your myTl.com account. Follow all the
online instructions. After completing the online instructions, you will receive an email
containing an attachment that is your license file.

Save the license file to your host PC, then return to the Welcome to Code Composer Studio

window and under Step 2 - Install License File, browse to where you saved the license file.
Click the OK button.

You will then be presented with the Code Composer Studio Welcome screen. Click on the
cube in the upper right-hand corner to go to the CCStudio workbench.

1% C/C++ - Cade Composer Studio (Licensed : 30 Days Remaining)

File Edit

jgate | Project Target Tools Serpts Window Help

Welcome to

Opy

9 C1Cee - Code Composer Studio (censed : 30 Days Rematning)

File Edt View MNavigate Project Target Toos 5o

e & Eo 7 H(@ere-J
_ C/C++ Projects X £ Outine

=3 An outing is not available:

4.4 Run Sample Test

As an example, we will run one feature test. In order to run a test program, you will have to select

the program, compile (or build) the program, and then load the compiled program. The following
steps will walk you through that process.

PN 1017268A
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From the menu bar, select Project > Import Existing CCS/CCE Eclipse Project.

$ C/C++ - Code Composer Studio (Licensed : 30 Days Remaining)

File Edit View Mavigate | Project Target Tools Scripts Window  Help
e & = |5z Build Active Project
%‘:,Rebuild Active Project

% Import Existing CCS/CCE Ediipse Project
ﬁlmpnrt Legacy CCSv3. 3 Project

Build All Ctrl+8
&7jRebuid Al Alt+B

Clean Selected File(s)

Build Selected File(s)

2. Browse to the location where you saved the BSL files on your host PC and down to the
OMAP-L138 GEL _BSL _Files v2.3\bsl directory. Click the OK button. Verify the correct
project exists in the Discovered projects: window and then click the Finish button.

PN 1017268A

@ Import CC5 Eclipse Projects

Select Existing CCS Eclipse Project
Select a directory to search for existing CC5 Eclipse projects. B

(®) Select search-directory: |C:\OMAP-L138_GEL_BSL_Files v2.3\| | Browse.. |

() Select archive file: | |

Discovered projects:

------ L evmomapl 138 _bsl (CNOMAP-L138_GEL_BSL Files w2 Select Al

Deselect Al

IEI[
i
-2

a | @

] Copy projects into workspace

(2) Finish ] [ Cancel
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3. Once again, select Project > Import Existing CCS/CCE Eclipse Project. This time browse
to the tests folder, OMAP-L138 GEL BSL v2.3\tests\experimenter. Click the OK button.

Verify the correct project exists in the Discovered projects: window and then click the Finish
button.

'@ Import CCS Eclipse Projects

Select Existing CCS Eclipse Project —
Select a directory to search for existing CCS Eclipse projects. E ;

(®) Select search-directory: |C:\OMAP-L138_GEL_BSL_Files_v2.3\| | Browse... |

() Select archive file: | |

Discovered projects:

e T evmomapl138_test_audio ({CMOMAP-L138_GEL_BS *"\] Select Al

i
E-

[#] T evmomapl 138 _test_emac_loopback_mii (C:\OMAP-| Deselect Al
[ ]|7|T=T evmomanl 138 testlemac loooback mii I'C:"-.OM[}-'-.P][V]
£ 1T >

(2) Finish ] [ Cancel

4. In the Projects window on the left, expand the evmomapl/138_bsl folder and verify the .ccxml
file is set as Active/Default. If not, right-click on the .ccxml file name and select Set as Active
Target Configuration, then repeat to also Set as Default Target Configuration.

$ C/C++ - Code Composer Studio (Licensed @ 26 [
File Edit View Mavigate Project Target Tools

e Sa © 3 -

S C/Css Projects X = O

< B &Y

=-1=% evmomapl138_bs
[E Includes
Ep inc

- b

—
evmomapl 138 .coamnl [Active/Default]

[]'[5':- av oot
'[Dl:- evmomapl138_test_emac_|oopback_mii

[ .
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5. Once again in the Projects window on the left, expand the evmomapl/138_test led dip
project. Right-click on the file name and select Set as Active Project.
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ﬁ C/C++ - Code Composer Studio (Licensed : 30 Days Remaining
File Edit View MNavigate Project Target Tools Scripts Wind

R~ < &

i C/C++ Projects X = O

E|{3_—E- evmomapl138_bsl
@ Includes
. = inc
= lib

Eb arc
[3;1.1 evmomapl 138.coxml [Active/Default]
'[DC evmomapl138_test_audio
'[Dc evmomapl138_test_cvideo
-[DC evmomapl138_test_emac_|loopback_mii
'[DC evmomapl138_test_emac_loopback _mii
'[Dc evmomapl138_test_image_sensor
TEC evmomapl138_test_led_char
'[Dc evmomapl138_test_lcd_graphics
TDC evmomapl138_tert -4 A=
f-125 evmomapl138 te:  MEW 4
'[DE evmomapl138_te: Go Into
‘= evmomapl138_te:
125 evmomapl138_te: Open in Mew Window
S evmomapl138_te
S evmomapl138_te
125 evmomapl 138 _te: Rebuild Index

BN tama

{7 Set as Active Project

6. The test must now be compiled; from the CCStudio menu bar select Project > Build Active
Project.

PN 1017268A

!—Build [evmomapl138_test_led_dip]

gmake: Nothing to be done for "all'.
Build complete for project evmomapll38_test_led dip

**%*% Build of configuration Debug for project evmomapll38 test_ led dip #****

C:%\Program Files\Texas Instrumentsiccsv4iutilsi\gmake'gmake -k all

] LE

Logic Product Development Company, All Rights Reserved
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7. Once the Console window prints the message “Build Complete,” select Target > Debug
Active Project from the menu bar. (NOTE: If you receive a message stating “Error
connecting to the target,” press the reset button on the baseboard and then click Retry.)

Progress [nformation

i J evmomapl138_test_led_dip...

| EEEEE |

Connecting to target Texas Instruments XD5100v1 USE Emulator_0/CE74X_0F

Mo operations to display at this time.

Cancel ][ << Details

8. After the test finishes debugging, you will see a message in the Console window stating “DSP
Wake Complete.”

B Console X
evmomapl138_test_led_dip [Project Debug Session] Texas Instruments XDS100v1 USE Emulator_0/CE74X_0 (10:53.04 AM)
C674X_0: Cmtput: Using mDDR =ettings
C674X O: Cmtput: mDDR init for 150 MHz is done
Ce74X 0: Output: = = -
C6T4X_0: Cutput: DS5F Wake Complete.
CET4X_0: Output: = oo m o
< ] 1l
0° B & LE

9. To run the program, select Target > Run from the menu bar.

PN 1017268A Logic Product Development Company, All Rights Reserved 11
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10. The Console window provides a brief description of the test. If you move any of the S2 DIP
switches, output text will print the switch that was moved and its new position (ON or OFF)
and USER LED1 or USER LED2 will turn on or off in relation to the DIP switch position.

B Console X

DIP switch[g]

8
(2}

DIP switch[g]

8
o

DIP switch[l]

DIP switch[1l]

was

was

was

was

switched

switched

switched

switched

ievmomapl 138_test_|led_dip [Project Debug Session] Texas Instruments

on

off

on

off

0* B E

The steps in this section can be repeated to run any of the other tests for your eXperimenter Kit.
(NOTE: All of the tests in the “experimenter” folder can be run on both the OMAP-L138 EVM and
eXperimenter Kit; the tests in the “evm” folder can only be run on the OMAP-L138 EVM.)
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Appendix A: Additional Documentation

Software Documentation

m The SD cards included with your OMAP-L138 eXperimenter Kit include Software Developer
Guides for Linux and Windows CE. Please see the setup.htm files on each SD card for
information.

m U-Boot documentation
http://www.denx.de/wiki/U-Boot/\WebHome

m Tl Code Composer Studio documentation
http://focus.ti.com/dsp/docs/dspsupportatn.tsp?sectionld=3&tabld=415&familyld=44&toolTyp
eld=30

Hardware Documentation

All of the following links are also available on your “My Account” page on the Logic PD website
(http://support.logicpd.com/auth/).

m Logic PD Zoom OMAP-L138 eXperimenter Kit QuickStart Guide
http://support.logicpd.com/downloads/1213/

m Logic PD Zoom OMAP-L138 eXperimenter Kit Hardware Design Files (BOMs, Schematics,
and Layout Files for all boards included in the eXperimenter Kit)
http://support.logicpd.com/downloads/1360/
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