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1 Introduction

The purpose of this document is to provide the necessary steps for creating a “Hello World”
sample application in Code Composer Studio (CCS) v5.1.0 for the DM3730/AM3703 SOM-LV,
DM3730/AM3703 Torpedo SOM, and DM3730/AM3703 Torpedo + Wireless SOM using the
Blackhawk XDS100v2 model D USB JTAG controller.

Section 3 addresses how to create the sample application for the DM3730 SOM-LV,
DM3730 Torpedo SOM, and DM3730 Torpedo + Wireless SOM. Section 4 addresses how to
create the sample application for the AM3703 SOM-LV, AM3703 Torpedo SOM, and
AM3703 Torpedo + Wireless SOM.

1.1 Nomenclature

m This document covers the DM3730 SOM-LV, DM3730 Torpedo SOM, and
DM3730 Torpedo + Wireless SOM. Use of “DM3730 SOM” suggests text that applies to all
three platforms; information specific to one platform will call out the precise name.

m This document also covers the AM3703 SOM-LV, AM3703 Torpedo SOM, and
AM3703 Torpedo + Wireless SOM. Use of “AM3703 SOM” suggests text that applies to all
three platforms; information specific to one platform will call out the precise name.

m  Use of “DM3730 Development Kit” suggests text that applies to both the DM3730 SOM-LV
Development Kit and DM3730 Torpedo SOM Development Kit; information specific to one
development kit will call out the precise name.

1.2 Requirements

This application note assumes the following:

m  Your DM3730 Development Kit or similar platform is properly assembled as described in the
appropriate QuickStart Guide.

o DM3730 Torpedo Development Kit QuickStart Guide*
o DM3730 SOM-LV Development Kit QuickStart Guide?

m  You are familiar with the User Guide associated with your DM3730 Development Kit or
similar platform.

o DM3730 Torpedo Development Kit User Guide®
o DM3730 SOM-LV Development Kit User Guide*

m You have the Blackhawk XDS100v2 model D USB JTAG controller.’(See Figure 1.1 below.)
IMPORTANT NOTE: Do not attach the Blackhawk XDS100v2 until CCS v5.1.0 has been
installed on your host PC.

! http://support.logicpd.com/downloads/1420/
2 http://support.logicpd.com/downloads/1421/
® http://support.logicpd.com/downloads/1450/
* http://support.logicpd.com/downloads/1449/
® http://www.blackhawk-dsp.com/products/USB100.aspx
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Figure 1.1: Blackhawk XDS100v2 with JTAG adapter

Your Blackhawk XDS100v2 must have the latest firmware. For information on how to update
to the latest firmware, please refer to the Texas Instruments’ (Tl) How Can | Update the
CPLD on My XDS100v2 wiki article.®

m Your host PC has an available USB port and active Internet connection.

2 Setup
This section explains how to install CCS v5.1.0 on your DM3730 SOM or AM3703 SOM and
connect the Blackhawk XDS100v2 to your DM3730 Development Kit.

2.1 Install CCS v5.1.0

Install CCS v5.1.0 if it is not already installed on your host PC. TI's Code Composer Studio v5
wiki article” provides information for properly installing the software.

Again, this application note was tested on and written specifically for CCS v5.1.0.

2.2 Connect the Blackhawk XDS100v2

1. Ensure the DM3730 Development Kit is assembled as described in the appropriate
QuickStart Guide.

2. Connect the Embedded Trace Macrocell™ (ETM) Adapter Board (included in the
development kit) to the SOM as documented in the appropriate DM3730 Development Kit
User Guide.

3. Connect the Blackhawk XDS100v2 to connector J3 on the ETM Adapter Board.

4. Using the USB cable provided, connect the Debug USB port on the baseboard to the
USB port on your host PC. (See the appropriate DM3730 Development Kit User Guide for the
location of this port on the baseboard.)

5. Power on the DM3730 Development Kit as documented in the QuickStart Guide.

3 Creating a “Hello World” Sample Application for the
DM3730 SOM

This section will describe the steps to create a “Hello World” sample application in CCS v5.1.0 for
the DM3730 SOM using the Blackhawk XDS100v2.

1. Download the necessary files:

a. On TI's Device Support files wiki page, ® download the DaVinci (DMxxxx) v1.0.3 files and
follow the directions in the “Usage” section on the same wiki page.

® http://processors.wiki.ti.com/index.php/XDS100#Q: How can | update the CPLD on my XDS100v2.3F
" http://processors.wiki.ti.com/index.php/Code_Composer_Studio V5

PN 1021646B Logic PD, Inc. All Rights Reserved. 2


http://processors.wiki.ti.com/index.php/XDS100#Q:_How_can_I_update_the_CPLD_on_my_XDS100v2.3F
http://processors.wiki.ti.com/index.php/XDS100#Q:_How_can_I_update_the_CPLD_on_my_XDS100v2.3F
http://processors.wiki.ti.com/index.php/Code_Composer_Studio_V5
http://processors.wiki.ti.com/index.php/Code_Composer_Studio_V5
http://processors.wiki.ti.com/index.php/Device_support_files
http://processors.wiki.ti.com/index.php/XDS100#Q:_How_can_I_update_the_CPLD_on_my_XDS100v2.3F
http://processors.wiki.ti.com/index.php/Code_Composer_Studio_v4

AN 529 Creating “Hello World” Sample Application in CCSv5.1.0 for DM3730/AM3703 SOMs

On TI's OMAP and Sitra CCS Support wiki page,® download the GEL files for the
DM3730 processor.

On TI's Linker CMD Files for CCS wiki page,* download the linker command file for the
DM3730 processor.

2. Create a temporary workspace in CCS v5.1.0 called HelloWorld as shown below and click

OK.

% Works pace Launcher f'5_<|

Select a workspace

Code Composer Studio stores your projects in a folder called & workspace.
Choose a workspace folder to use For this session.

Wiorkspace: | C:hoesvSiHelloorld v| [ Browse. ..

[ Use this as the default and do not ask again

[ K H Cancel l

3. Close the Tl Explorer page and create a hew project in the CCS Edit perspective by selecting
File > New > CCS Project.

8 http://processors.wiki.ti.com/index.php/Device_support_files

® http://processors.wiki.ti.com/index.php/OMAP_and _Sitara CCS support#DM3730 and DM3725

0 http://processors.wiki.ti.com/index.php/Linker CMD_Files for CCS#DaVinci"
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4. Inthe New CCS Project window, choose the settings that best match your configuration and
click Finish. An example of one possible configuration is shown below.

% New CCS Project

CCS Project

Create a new CCS Project,

Project narme: | SampleProject |

Qutput bype: | Executable “ |

Use default location

| Erowse, ..
Device
Eamb:  |ceoon v|
ariant: | DraVinci DM3 7 L | |DM3?30 R |
Connection: |Texas Instruments ¥DS5100vZ USE Emulator hd |

» Advanced settings

* Project templates and examples

Simple Hello World executable application
printing the string "Hello World!" to standard

= E Empty Projects A | oukpuk,
[& Empty Project
E Py ol ol | . Although this is a simple example, it is not
E Empky Assembly-only Project recommended for devices with small
|71 Empty RTSC Project memaory-maps (such as the MSP430 or CZ000
=-[=] Basic Examples families of devices),|
E Hello Warld =
[ ceFlo Examples
|=| DSPJBIOS vwE.xx Examples
-F=] 1B and Tin Framnles 59
@ = Back Mext = Finish l [ Cancel
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5. Add the DM3730.cmd file downloaded above in Step 1c by right clicking [Project Name] and
then selecting Add Files... as shown below. Navigate to where you have the DM3730.cmd
file saved, select Open, and choose to copy it into the workspace.

r[\jProject Explorer &3 = <,==='p ¥ =0

S o

. 3
SR
] b 2 Copy Chrl+C
%D

¥ Delete Delete
Source 4

Rename... F2

Eug Import. ..
£ Export. ..

Build Options. ..

Build Project

Clean Project

Refresh F5

Close Project

|6€>

Build Configurations 4
IMake Targets 4
Index 4
add Files. ..

Debug As 4
Team 4
Compare with 4
Restare Fram Local History, ..

Source [
Refactor 4
Properties alt-+Enker 1
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6. Edit your target configuration file by double clicking on DM3730.ccxml in your Project window.
Choose the Advanced section (circled below in red) and click on the Cortex_A8_0 option.
Browse to the folder that contains the GEL files downloaded in Step 1b. From those files,
choose the am-dm37x_cortexA.gel file and click Open.

1] elcn iil s Hﬁ

Tardgel Cordicgural lon

B F e Bl E g Ve Birs.
______ — Corfma _A8 CPUF
3 T Tenss Eretruments 3061007 LGH Dailstor | Bt
= W e e, St e prapertes of the sslerhed o
= B sesbud 2 0 L. ) Clhoes
= 0 Subeuh 8 AT
& o o L 0
= Subpath 7 [ Sharves P
h ?gwmhﬁ:; ke Dok 1000
g (e
A ca_chid 1 Tt Conmaction |
B s e 2
= e Subgath b
& om0
Open BiE
Lok i | [ DMOTE0-S_GELs_ (XS e e B R
| !wdu.'l:'nm_-:crﬂw el
iy Flacend JCortenid CrowTeggm gel
Dusturarts FJeortensd el onl
= {otm_cortm il ity gl
[__& oo e _pesats gel
Dedhices oo 00 _pwor_pksch_sonfige. gal
7 Jomap 30 pecorfipure_firssal g
L=
ey Dhaumeniy
wi
My Coorpuien
Q“ q il b vt Ta_ ey puol - -m
L o by Hotpeh. Pl of B [ 3 l_t’_'“l_ —
121 P £
Nkees
[eseriphion. = Winrie Pt s i Proe

7. Build the project by right clicking on [Project Name] and selecting Build Project.
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8. Now we want to launch the target configuration. To do this, select View >
Target Configurations in the CCS Edit perspective.

File Edit m Mawigake Project Run  Scripts

r<=- - LE:J TI Resource Explarer )
|

-

|-_|}_‘| Projec PD Project Explorer [, 5
== H o= Outline
Al E_l, Prablems

Lg El Console

I
R % Debug

ﬂ Target Configurations
Scripking Console

=50 Disassembly

[0 Memary Browser
W Regiskers
l5'3::;"E:-:|:nn355in:u|'|s
(=)= Variables

B Breakpoints

Cther, ..

9. Inthe Target Configuration window, navigate to your target configuration file by selecting
Projects > Hello World. Right click on the DM3730.ccxml file and choose Launch Selected
Configuration.

= B % Target Carfigura... &2 — O
- &
= B X &3

[=-1==% Projects
=-1=% Hellotworld

il DM3730.conmi [

|2 Mew Target Configuration

¥ Delete Delete
Fename Fz
i Refresh Fg

ﬁ Launch Selected Configuration

Set as Defaulk
Link File To Project r

Propetties Alk+Enter
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10. To connect to the ARM core, right-click on Texas Instruments XDS100v2 USB
Emulator/Cortex_A8 0 and select Connect Target.

%5 Debug 52 %% 3 7 % LA @9 = = O ||09= variables 52 |65 Expl
= &%) DM3730. coxml [Code Composer Studio - Device Debugging] Mame
ﬁ Texas Instrurments ¥D5100v2 USE Emulator/Ce4xP_0 (Disconnecked @ Unknown)
Texas Instruments XDS100w2 USE Emulakor/Cortes_aG_0 (Disconnected : Unknowrp

B Conneck Target Chrl+-alt+C

Enable Halt On Reset

Open GEL Files Wigw

¥ Hide core(s)
Show all cores

%) DMa730.coxml &2 Group carels)

Ungroup corefs)

Target Configuration

All Connections
%Relaunch

WYEdit DM3730.coxml...

= T, Texas Instruments ¥DS100v2 USE Emulator

=48 DM3730
=-%3% IcePick_C_0 ¥, Terminate and Remove
= Q Subpath_0 Terminate,l'Disconnect All
G ceawp_n

= Q Subpath_2

T =

11. Run a script to wake up the DSP by selecting Scripts > IVA2200_Startup >
IVA22_GEM_startup.

if= L] DOSE Ta) [
mn Window  Help
b Va2 I
IVAaZ200_MrL P T
[ vazz00_PD P L T O 9= variables B2 |99 E:
D '-.-'-.-'atu:thg§ [ 1 .
- Debug Durinng WEL »
. CortexhAs Features 4
oF MNEDN ]
OMARSSxx_Resets L4
SECURITY 3
PRCM_CLOCK _COMNFIGS ]
DRAMS [ 3
Cross Triggering [ 3
Embedded_Trace_Macrocel{ETM)_Reqgisters  »

PN 1021646B Logic PD, Inc. All Rights Reserved. 8
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12. Now connect to the DSP core the same way you connected to the ARM core by right-clicking
on 0x402063E4 and selecting Connect Target.

%5 pebug &2 [ Ll 3T V&'@ ﬁ@v:'ﬁ )=y
= ¢ DM3730.coxml [Code Composer Studio - Device Debugging] Mlarm
=g Texas Instruments ¥05100v2 USE EmulakorCa43P_0 (Suspended)
= 020 {no symbols are defined For Ox402063E4)
=g Texas Instruments ¥DS100vZ USE Emulator/Cortex A8 01 v T Connect Target Chri+Ak+C
= 0x0001408C (no symbols are defined For 0x0001408C Disconnect Target Cr+A+D

Enable Global Breakpoints
Enable Halt On Reset

Open GEL Files Wiew

3 Hide coreds)
Show all cores
Group corels)
Ungroup corels)

%Relaunch

KIEdit DM3730.coxml. .
Eh Terminate and Remove

Terminate,l'Discu:nnnect all

13. Download the program onto the DSP by selecting Run > Load > Load Program....
Scripks  Window  Help

o | w B Connect Targst Chr-AlE+C
Disconnect Target Chrl+AlE+D

O || 6= variables 52 | 47 Expressions | 05

ol B B ieadPogan. Gk
N
H [ Resume Fa
T @, Load Symbols. ..
Add Symbals, ..
a Terminate Chrl+F2 $<} 4

K&Reset L4

@Restart
TL_Step Inta F5

14. Choose Browse Project and select the Helloworld.out file. Click OK twice.

15. Run the program. You should see “[C64XP_0] Hello World!” in the console window.

PN 1021646B Logic PD, Inc. All Rights Reserved. 9
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Creating a “Hello World” Sample Application for the

AM3703 SOM

This section will describe the steps to create a “Hello World” sample application in CCS v5.1.0 for
the AM3703 SOM using the Blackhawk XDS100v2.

1. Download the necessary files:

a.

On TI's Device Support files wiki page, * download the Sitra (AMxxxx) v1.0.3 files and
follow the directions in the “Usage” section on the same wiki page.

On TI's OMAP and Sitra CCS Support wiki page,** download the GEL files for the
DM3730 processor.

On TI's Linker CMD Files for CCS wiki page,*® download the linker command file for the
DM3730processor.

2. Create a temporary workspace in CCS v5.1.0 called HelloWworld as shown below and click

OK.

% Works pace Launcher El

Select a workspace

Code Composer Studio stores your projects in a folder called & workspace.
Choose a workspace Folder to use for this session.

Wiorkspace: | C:hoesvSiHelloorld v| [ Browse. ..

[ Juse this as the default and do not ask again

[ K H Cancel l

3. Close the Tl Explorer page and create a hew project in the CCS Edit perspective by selecting
File > New > CCS Project.

! http://processors.wiki.ti.com/index.php/Device _support_files

12 http://processors.wiki.ti.com/index.php/OMAP_and_Sitara CCS support#DM3730 and DM3725

13 http://processors.wiki.ti.com/index.php/Linker CMD _Files_for CCS#DaVinci"

PN 1021646B
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4. Inthe New CCS Project window, choose the settings that best match your configuration and
click Finish. An example of one possible configuration is shown below.

& New CCS Project (=13

CCS Project

Create a new CCS Project,

Project name: | Hella'Warld |

Qutput bype: | Executable “ |

Use default location

| Erowse, ..
Device
Eamiyi | ARM v|
ariant: | AM37x - Corkex AS L | |AM3?03 R |
Connection: |Texas Instruments ¥DS5100vZ USE Emulator hd |

» Advanced settings

* Project templates and examples

Simple Hello World executable application
= printing the string "Hello World!" to standard
[=+||= Empty Projects A | oukpuk,
[& Empty Project
E Py ol ol | . Although this is a simple example, it is not
E Empky Assembly-only Project recommended for devices with small
|71 Empty RTSC Project memory-maps (such as the MSP430 or CZ000
=-[Z] Basic Examples Families of devices),
s
[= 1PC and 1o Examples L
|5 svse1os
-T=] Suetem dnakwzer fIT8Y 59
@ = Back Mext = Finish l [ Cancel

PN 1021646B Logic PD, Inc. All Rights Reserved. 11
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Add the DM3730.cmd file downloaded above in Step 1c by right clicking on [Project Name]

and selecting Add Files... as shown below. Navigate to where you have the DM3730.cmd file
saved, select Open, and choose to copy it into the workspace.

= [:(_—cj- HelloWorld [Active - Deb

Bl Includes
L€ hello.c

[# amMazaz.coml [Active/Del

b

EI W [ [P, DT S

M

Copy ChrlHHC

Deleke Deleke
Source

Rename,.. Fz

£ Impart, .

e

f39

Export. ..

Build Options. ..

Build Project

Clean Project

Refresh F5

Close Project

Build Configurations
Make Targets
Index

#dd Files. ..
Debug As
Team

Compare with

Restore from Local Histary...
Saurce

Refactor

Properties Alb+Enker

Logic PD, Inc. All Rights Reserved.
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6. Edit your target configuration file by double clicking on the AM3703.ccxml file in your Project
window. Choose the Advanced section (circled below in red) and click on the Cortex_A8 0
option. Browse to the folder that contains the GEL files downloaded in Step 1b. From those
files, choose the am-dm37x_cortexA.gel file and click Open.

2] hella.c ﬁ o =0
Target Configuration B (&) =
All Connections Properties
= T, Texas Instruments ¥05100v2 USE Emulator Impart... AT
= w AMITO3 he properties of the selected cpu,
=% TeePick_C_0 Mew, ypass
= Q Subpath_2 add lizati .
=8¢ C5_DAP_PC_0 lization script [y, \DM3730-25_GELs_CCSv4\am-dm37x_cortexd.gel | [Bm&]
=X Subpath_3 Delete lave Processor
& one b (owonm |
ﬁ]: cs_child_1 [
ﬁ]: cs_child_2
G csete_0
Open @
Look jr: | £ DM3730-25_GELs_CCSvd v @@ e m-
T J am-dm37x_cortexA,gel
i 2) ﬂam-de?x_sdrc_conFigs.gel
My Recent J CortexAl_CrossTrigger.gel
Documents J corkexcAs_util.gel
= J etm_cortexAS_registers,gel
|_ J omap35xx_tesets.gel
Dieskiop ﬂ0map3430jrcm_clock_configs.gel
J omap3430_reconfigure_firewalls, gel
=7
My Documents
tdy C;jmpuler
‘g File name: A | [ Open ]
MyMNetwork | Filesof type: | Gel Files [ gel v| [ _cancal | 5
Basi(ﬂdvanced}:urce -
& cons | =5~ = O || Bl problems 22
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7. Change the Device endianness of the project by right clicking on [Project Name] and

selecting Properties. In the General tab, change the Device endianness to little and click OK.

L Properties for HelloWorld

Resource
General
=~ Build

[=)- TMS470 Compiler
Basic Options
Assembler Options
Command Files
Defaulk File Extensions
Diagnostic Oplions
Directary Specifier
Entry Exit Hook Options
File Tvpe Specifier
Include Options
Language Cptions
Library Function Assumptions
MISRA-C:2004: MISRA Rules
Optimizations
Parser Preprocessing Options
Predefined Symbals
Runtime Madel Options
Symbaolic Debug Options

TM3470 Linker

Debug

@ Show advanced settings

General

Configuration: |Debug [ Active ]

Device
Eannily:

‘Wariankt:

E Main |

hd | ’Manage Configurations...

Cutput Bype:

Device endianness:
Compiler wersion:
Output format:

Linker command File:

| <select or type filker text=

v | [amz703

]

Conneckion: |Texas Instruments ¥05100v2 USE Emulator

w | {applies to whole project)

w Advanced settings

[T1was v [ more.. |
|Iegacy COFF - |
| DM3730.cmd v| [ Browse. .. ]

Runtime support library: | <attamatic =

V|[ Browse. . ]

Restore Defaults

[ O, l ’ Cancel

l

8. Build the project by right clicking on [Project Name] and selecting Build Project.

PN 1021646B
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9. Now we want to launch the target configuration. To do this, select View >
Target Configurations in the CCS Edit perspective.

Mavigake Projeck

Wiew

File Edit

f¢' - LE:J TI Resource Explarer 5 .
|

[ Projec [ Project Explorer [ E
2= H o= Qutline

ﬁ_! [£/ problems
il B Consale

@
Lg#.«)‘a[ﬁlehug

E B4 Target Configurations
[T @ Scripting Console

ﬂ Memory Browser
W41 Registers

*fFC'" Expressions
()= Yariables

g Breakpoints

Cther. ..

10. In the Target Configuration window, navigate to your target configuration file by selecting
Projects > Hello World. Right click on the AM3703.ccxml file and choose Launch Selected

Configuration.

— B % Target Corfigura... 2 — O
- )
= & X &3
[=)=F Projects
[=-1=% Helloworld

=

CIr
= |al
|

[Z Mew Target Configuration

E ¥ Delete Delete
Rename Fz
i Refresh FS

ﬁ Launch Selected Configuration

Set as Defaulk
Link, File To Project

Properties Alt+Enter

PN 1021646B Logic PD, Inc. All Rights Reserved.
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11. To connect to the ARM core, right-click on Texas Instruments XDS100v2 USB
Emulator/Cortex_A8 0 and select Connect Target.

%Debug 23 5% 6T % - E @4} = = O || t9= variables 532 si"-fExpressin
= &% AM3703. coxml [Code Composer Studio - Device Debugging] Marme
x@ Texas Instrumen USE Emulatar/Corte _0 {Disconnecked : Lnk ¥

M Connect Target Cerl+al+C

Enable Halk On Reset

Cpen GEL Files Yiew

¥ Hide core(s)
Show all cores
Group coreis)

[ hella.c %) AM3703.coml &2 Ungroup corels)

Target Configuration

All Connections %Relaunch rtie
.y CPL
= T, Texas Instruments ¥D5100v2 156 Emulator ke Edit AMIT0Z.coml..
= w AMIT03 Eﬁ Terminate and Remaove petl
=3 Iepick_C 0 [ TerminateyDisconnect Al

= Q Subpath_z
=% Cs_pap_PC_0
=] Q Subpath_3 | Delete [T elave Proace

N scl

12. Download the program onto the ARM core by selecting Run > Load > Load Program....

Iﬂ Scripks Window  Help

o | w Bl Connect Targst ChrH-Alk+-C

Disconnect Target Chrl+Al+D
& B || 69= variables 52 | &4 Expressions | A5
u E Load E Load Program. .. ChrH-AlEHL
u
E [ Resume Fa
T [;Eb Load Symbals. ..

Add Symbals, .

a Terminate Chrl+F2 $ 4

@&Reset L

{;:;.Restart
T Step Inka FS

13. Choose Browse Project and select the HelloWorld.out file. Click OK twice.

14. Run the program. You should see “[Cortex_A8_0] Hello World!” in the console window.

PN 1021646B Logic PD, Inc. All Rights Reserved. 16
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5 Troubleshooting

This section shows what the correct output of the console should be when connecting to the
DM3730 SOM and the AM3703 SOM.

5.1 DM3730 Console Expected Output

Cortex_ A8 O:
Cortex_ A8 O:
Cortex_ A8 O:
proceeding

Cortex_ A8 O:
Cortex_ A8 O:
completed

Cortex_A8 O
Cortex_A8 O
Cortex_A8 O
Cortex_A8 O
Cortex_A8 O
Cortex_A8 0O:
Cortex_A8 0O:

CS0O, 16M x 32bit x 4Banks

Cortex_ A8 0O:
Cortex_ A8 0O:
Cortex_ A8 0O:
Cortex_ A8 0O:
completed

Cortex_A8 0O:
Cortex_A8 0O:
Cortex_A8 0O:
Cortex_A8 0O:
CortexA8. ..
Cortex_A8 0O:
register. ..
Cortex_A8 0O:
Cortex_A8 0O:
Cortex_A8 0O:
Cortex_A8 0O:

GEL
GEL
GEL

GEL
GEL

GEL
GEL
GEL
GEL
GEL
GEL
GEL

GEL
GEL
GEL
GEL

GEL
GEL
GEL
GEL

GEL
GEL

GEL
GEL

Output:
Output:
Output:

Output:
Output:

Output:
Output:
Output:
Output:
Output:
Output:
Output:

Output:
Output:
Output:
Output:

Output:
Output:
Output:
Output:

Output:
Output:

Output:
Output:

OMAP 32K Watchdog Timer is disable
Putting DPLL into bypass before proceeding
Putting CORE DPLL into bypass before

Locking CORE DPLL
PRCM clock configuration 1lA setup has been

SystemClock = 26.0 MHz

DPLL_MULT_VALUE = 332

DPLL_DIV_VALUE = 25

CORE_DPLL_CLK = 664.0 MHz

CORE_CLK = 332.0 MHz

L3 _CLK = 166.0 MHz
mDDR Hynix H8KDSOUNOMER - 2048 Mbit(256MB) on

Waiting for SDRC DLL to lock...

SDRC DLL successfully locked
common_sdram_init() completed

SDRC initilization for mDDR Hynix H8KDSOUNOMER

26MHz clock configuration lla
26MHz clock configuration lla

CORTEXA8_ CORE_VERSION = 0x413FC082
Target contains version r3p2 of the

Read the ETM_POWER_DOWN_STATUS
ETM_POWER_DOWN_STATUS = 0x00000001

ETM Access is enabled!
ETM_ID = 0x410CF236

result: C64x+ release from reset

5.2 AM3703 Console Expected Output

Cortex_ A8 O:
Cortex_ A8 O:
Cortex_ A8 O:
proceeding

Cortex_ A8 O:
Cortex_ A8 O:
completed

Cortex_ A8 O:
Cortex_ A8 O:
Cortex_ A8 O:
Cortex_ A8 O:

PN 1021646B

GEL
GEL
GEL

GEL
GEL

GEL
GEL
GEL
GEL

Output:
Output:
Output:

Output:
Output:

Output:
Output:
Output:
Output:

OMAP 32K Watchdog Timer is disable
Putting DPLL into bypass before proceeding
Putting CORE DPLL into bypass before

Locking CORE DPLL
PRCM clock configuration 1lA setup has been

SystemClock = 26.0 MHz
DPLL_MULT_VALUE = 332
DPLL_DIV_VALUE = 25
CORE_DPLL_CLK = 664.0 MHz

Logic PD, Inc. All Rights Reserved. 17
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Cortex A8 0O: GEL
Cortex A8 0O: GEL
Cortex A8 0O: GEL
CSO, 16M x 32bit
Cortex A8 0O: GEL
Cortex A8 0O: GEL
Cortex A8 0O: GEL
Cortex A8 0O: GEL
completed
Cortex A8 0O: GEL
Cortex A8 0O: GEL
Cortex A8 0O: GEL
Cortex A8 0O: GEL
CortexA8. ..
Cortex A8 0O: GEL
register. ..
Cortex A8 0: GEL
Cortex A8 0: GEL
Cortex A8 0: GEL

PN 1021646B

Output: CORE_CLK = 332.0 MHz

Output: L3 CLK = 166.0 MHz

Output: mDDR Hynix H8KDSOUNOMER - 2048 Mbit(256MB) on
X 4Banks

Output: Waiting for SDRC DLL to lock...

Output: SDRC DLL successfully locked

Output: common_sdram_init() completed

Output: SDRC initilization for mDDR Hynix H8KDSOUNOMER

Output: 26MHz clock configuration lla

Output: 26MHz clock configuration lla

Output: CORTEXA8_CORE_VERSION = 0x413FC082
Output: Target contains version r3p2 of the

Output: Read the ETM_POWER_DOWN_STATUS
Output: ETM_POWER_DOWN_STATUS = 0x00000001

Output: ETM Access is enabled!
Output: ETM_ID = 0x410CF236

Logic PD, Inc. All Rights Reserved. 18
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