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1 Introduction 
This User Manual provides information pertaining to Logic PD’s OMAP35x Windows Embedded 
CE 6.0 Board Support Package (BSP). 

1.1 Document Notes 
Nomenclature 

The OMAP35x Windows CE 6.0 Source BSP is compatible with both the OMAP35x SOM-LV and 
OMAP35x Torpedo SOM platforms. Within this User Manual, “OMAP35x Development Kit” is 
used to refer to both the Zoom™ OMAP35x (SOM-LV) Development Kit and the Zoom OMAP35x 
Torpedo Development Kit. Where information only pertains to one kit, the individual kit name will 
be used to make that clear. 

Note on Images 

The images of screen captures included in this User Manual exist only as examples of what may 
appear on your PC display during software installation and use of the BSP; please note that 
version numbers, file names, and other items may differ from the current release. 

2 Download Windows CE Source BSP 
The first step in using Logic PD’s Windows CE BSP is to download the most current source BSP 
release from Logic PD’s website.  

2.1 Prerequisites 
■ OMAP35x Development Kit registered on Logic PD’s website 

□ Registration is required to grant you access to your product’s download page from where 
the BSP can be downloaded 

■ Host PC 

■ Internet connection 

2.2 Download Steps 
1. Depending on the OMAP35x Development Kit you are using, click on the appropriate link 

below to open a web browser to the downloads page. (If you are not already logged in, you 
will need your username and password that was setup during registration to access the 
downloads page.) 

Zoom OMAP35x (SOM-LV) Development Kit Downloads Page 
Zoom OMAP35x Torpedo Development Kit Downloads Page 

2. Under the Windows CE category, click on OMAP35x Windows CE 6.0 Source BSP to begin 
the download. 

3. Save the file to your PC. 

4. After the download completes, locate the 101xxxx_OMAP35x_WinCE600_x_x_x_Source.zip 
archive on your PC. 

5. Unzip the 101xxxx_OMAP35x_WinCE600_x_x_x_Source.zip archive to a directory of your 
choice. 

http://support.logicpd.com/auth/downloads/OMAP35x%20Zoom%20Development%20Kit/#wince�
http://support.logicpd.com/auth/downloads/Zoom%20OMAP35x%20Torpedo%20Development%20Kit/#wince�
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6. After unzipping 101xxxx_OMAP35x_WinCE600_x_x_x_Source.zip, visually verify that the 
following sub-directories and files have been created: 

logic_som_omap35xx_source_readme.txt 
Windows CE Development Prerequisites.txt  
.\Binaries  
 \<OS Design Name> 

\<Platform Name> 
\several NK.bin files 

\LogicLoader_Scripts 
.\Documentation 
 Driver Description documents for specific components 
 Feature Matrix 
.\OSDesigns 
 \<OS Design Name> 
.\PLATFORM 
 \COMMON\SRC\SOC\<SOC Name> 
  Several subfolders and files 
 \<Platform Name> 
  Several subfolders and files 
 

7. Take special note of the two text files at the root level: 
logic_som_omap35xx_source_readme.txt and Windows CE Development Prerequisites.txt. 
Both of these files will be referenced later in this User Manual. 

2.3 Next Steps 
From this point, you can continue through this User Manual in order or, based on the following 
descriptions, you can jump to the section that is most appropriate for your use. 

■ Section 3 “Sample Pre-Built Images” describes how you can use the pre-built NK.bin binary 
files (included in the BSP download) to evaluate the BSP on the OMAP35x Development Kit. 
These NK.bin files are loaded to the OMAP35x Development Kit via an external source (SD 
card, CompactFlash card, or Ethernet). 

■ Section 4 “Prepare for Windows CE Development” walks you through installing the evaluation 
version of Windows Embedded CE 6.0 on your host PC, including Visual Studio 2005 and 
Platform Builder. If you already have these programs installed on your PC, you can skip this 
section. 

■ Section 5 “Build Logic PD’s Windows CE Source BSP” describes how to begin Windows CE 
development using Logic PD’s BSP and OMAP35x Development Kit. Visual Studio 2005 and 
Platform Builder must be installed on your host PC before proceeding with this section. 
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3 Sample Pre-Built Images 
This section describes how to load a Windows CE pre-built image (NK.bin) on the OMAP35x 
Development Kit using three different methods: SD card, CompactFlash card, and Ethernet. 

Sample NK.bin binary files allow you to evaluate Logic PD's BSP on the OMAP35x Development 
Kit. They are also useful for application development since each image includes helpful libraries 
and a variety of drivers. Logic PD’s sample NK.bin images are not meant for production and 
should not be regarded as production-ready. 

3.1 Prerequisites 
■ Tera Term terminal emulator (or equivalent). 

■ The most current Windows CE Source BSP release, as described in Section 2. 

■ An SD card or CompactFlash card with a capacity of at least 32 MB—this card must be large 
enough to store the sample NK.bin file. 

■ An Ethernet cross-over cable. 

3.2 Load Pre-Built Image via SD Card 
This section describes how to load the NK.bin image from an SD card using LogicLoader and 
then boot the image. 

1. Locate the 101xxxx_OMAP35x_WinCE600_x_x_x_Source file that you extracted in 
Section 2. 

2. Read through the logic_som_omap35xx_source_readme.txt to learn of any dependencies 
specific to the most current release. 

3. Navigate to the .\Binaries\<OS Design Name>\ directory and you will find several NK.bin files. 

4. Copy the <SOM_Type>_NK.bin file from that directory to an SD card. (Make sure to copy the 
appropriate file for your OMAP35x Development Kit.) 

5. Insert the SD card into the OMAP35x Development Kit’s SD card slot. NOTE: For the 
OMAP35x Torpedo Development Kit, use the primary SD card slot (J21) located closer to the 
middle of the baseboard edge.  

6. Verify the OMAP35x Development Kit is connected to the host PC via serial cable and is 
connected to the power supply. (Detailed instructions for these connections can be found in 
the respective OMAP35x Development Kit User Manuals.) 

7. Launch Tera Term on the host PC. 
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8. In Tera Term, select Setup > Serial port... from the menu bar. Set the Baud rate to 115200, 
Data to 8 bit, Parity to none, Stop to 1 bit, and Flow control to none. 

 
9. Power on the OMAP35x Development Kit and verify the LogicLoader prompt appears in the 

terminal emulator window. 

10. Mount the SD card in LogicLoader by typing: mount fatfs /dev/sdmmc0a /sd 

 



OMAP35x WinCE 6.0 BSP User Manual 

PN 1016591D Logic PD, Inc. All Rights Reserved. 5 

11. Type cd /sd and press the Enter key to change directories to the SD card. 

12. Type ls to list the contents of your SD card and confirm the <SOM_Type>_NK.bin file is on 
the card. 

 
13. Type load bin <SOM_Type>_NK.BIN (use the correct NK.bin filename) and press the 

Enter key to load the NK.bin into RAM. IMPORTANT: LogicLoader is case sensitive, so be 
sure to type the filename the same way it appears in LogicLoader after using the ls 
command. 

 

 
14. When the losh> prompt returns after displaying Checksums good. file loaded, your 

NK.bin has been successfully loaded into system RAM and is ready to boot.  

NOTE: The sample NK.bin images provided on Logic PD’s website run from system RAM 
and cannot be burned to system flash. Since the sample NK.bin images are volatile, they 
need to be loaded from a external source (like an SD card) after every power cycle. 



OMAP35x WinCE 6.0 BSP User Manual 

PN 1016591D Logic PD, Inc. All Rights Reserved. 6 

15. Type exec and press the Enter key to boot the NK.bin.  

 
16. Immediately, the kit LCD should turn on. In Tera Term, you will see a message stating 

Starting Kernel... and then other output messages. 

17. After allowing time for the image to boot, the kit LCD may prompt you to calibrate the 
touchscreen by pressing a stylus to the center of cross-hairs on the screen. If necessary, 
follow the onscreen instructions and the NK.bin will boot and display the Windows Embedded 
CE 6.0 GUI on the kit LCD. 

 

3.3 Load Pre-Built Image via CompactFlash Card 
NOTE: This section only applies to OMAP35x (SOM-LV) Development Kit; the OMAP35x 
Torpedo Development Kit does not have a CompactFlash card slot. 

The process for loading a sample image via CompactFlash card is very similar to the SD card.  

1. Locate the 101xxxx_OMAP35x_WinCE600_x_x_x_Source file that you extracted in Section 
2. 

2. Read through the logic_som_omap35xx_source_readme.txt to learn of any dependencies 
specific to the most current release. 
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3. Navigate to the .\Binaries\<OS Design Name>\ directory and you will find several NK.bin files. 

4. Copy the SOM_LV_NK.bin file from that directory to a CompactFlash card. 

5. Insert the CompactFlash card into the OMAP35x Development Kit’s CompactFlash card slot. 

6. Verify the OMAP35x Development Kit is connected to the host PC via serial cable and is 
connected to the power supply. (Detailed instructions for these connections can be found in 
the Zoom OMAP35x Development Kit User Manual.) 

7. Launch Tera Term on the host PC. 

8. In Tera Term, select Setup > Serial port... from the menu bar. Set the Baud rate to 115200, 
Data to 8 bit, Parity to none, Stop to 1 bit, and Flow control to none. 

 
9. Power on the OMAP35x Development Kit and verify the LogicLoader prompt appears in the 

terminal emulator window. 



OMAP35x WinCE 6.0 BSP User Manual 

PN 1016591D Logic PD, Inc. All Rights Reserved. 8 

10. Mount the CompactFlash card in LogicLoader by typing: mount fatfs /dev/ata0a /cf 

 
11. Type cd /cf and press the Enter key to change directories to the CompactFlash card. 

12. Type ls to list the contents of your SD card and confirm the SOM_LV_NK.bin file is on the 
card. 

 
13. Type load bin SOM_LV_NK.BIN and press the Enter key to load the NK.bin into RAM. 

IMPORTANT: LogicLoader is case sensitive, so be sure to type the filename the same way it 
appears in LogicLoader after using the ls command. 
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14. When the losh> prompt returns after displaying Checksums good. file loaded, your 

NK.bin has been successfully loaded into system RAM and is ready to boot.  

NOTE: The sample NK.bin images provided on Logic PD’s website run from system RAM 
and cannot be burned to system flash. Since the sample NK.bin images are volatile, they 
need to be loaded from an external source (like an SD card) after every power cycle. 

15. Type exec and press the Enter key to boot the NK.bin.  
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16. Immediately, the kit LCD should turn on. In Tera Term, you will see a message stating 
Starting Kernel... and then other output messages. 

17. After allowing time for the image to boot, the kit LCD may prompt you to calibrate the 
touchscreen by pressing a stylus to the center of cross-hairs on the screen. If necessary, 
follow the onscreen instructions and the NK.bin will boot and display the Windows Embedded 
CE 6.0 GUI on the kit LCD. 

 

3.4 Load Pre-Built Image via Ethernet 
This section describes how to download the OS image via Ethernet in LogicLoader (LoLo). It is 
assumed that a TFTP program has been installed on your PC. 

1. Place the <SOM_TYPE>_NK.bin file in your TFTP folder. 

2. Launch your TFTP program. 
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3. Start Tera Term type ifconfig and press the Enter key to initialize the Ethernet port. 

4. Then type ifconfig sm0 dhcp and press the Enter key to start DHCP.  

5. Finally type ifconfig and press the Enter key to obtain an IP address. 

 
6. Type load bin /tftp/<x.x.x.x>:<SOM_TYPE>_NK.bin (use the correct IP address 

and NK.bin filename for your setup) and press the Enter key. 

 

 
7. Type exec and press the Enter key to boot the NK.bin. 
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8. After allowing time for the image to boot, the kit LCD may prompt you to calibrate the 
touchscreen by pressing a stylus to the center of cross-hairs on the screen. If necessary, 
follow the onscreen instructions and the NK.bin will boot and display the Windows Embedded 
CE 6.0 GUI on the kit LCD. 
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4 Prepare for Windows CE Development 
This section describes the steps required to prepare your PC for Windows CE development. 

4.1 Prerequisites 

■ Host PC with DVD drive (DVD drive only required if using the Windows Embedded CE 6.0 
180-Day Evaluation Kit). 

■ A current version of Internet Explorer, Firefox, or other web browser and access to the 
Internet. 

■ Windows Embedded CE 6.0 180-Day Evaluation Kit included with your OMAP35x (SOM-LV) 
Development Kit or equivalent downloads from the Microsoft Windows Embedded CE 
website. 

■ Windows CE Development Prerequisites.txt file included with the Logic PD Windows CE 
source BSP release. 

4.2 Installation Overview 
This section will walk you through the recommended installation steps for Visual Studio 2005 and 
Platform Builder. The following is a high-level look at the installation process: 

1. Update your PC using Windows Update. 

2. Install Visual Studio 2005 from the Windows Embedded CE 6.0 180-Day Evaluation Kit 
provided with the OMAP35x (SOM-LV) Development Kit or from the Microsoft Windows 
Embedded CE website. 

3. Update Visual Studio from the Windows Update website, which includes the Visual 
Studio 2005 Service Pack 1. 

4. Install Platform Builder from the Evaluation Packet. 

5. Update Platform Builder.  

NOTE: Different versions of Logic PD’s Windows CE BSP may require specific Microsoft 
Platform Builder updates. Since Microsoft releases monthly patches to Windows CE, 
please refer to the Windows CE Development Prerequisites.txt file to determine which 
updates pertain to your BSP version. This text file is located in the base directory of the 
Logic PD Windows CE BSP source package. 

6. Run Visual Studio 2005. 

7. Run the QFE Check tool from Visual Studio 2005 

IMPORTANT NOTE: This document is written assuming the use of the Windows XP operating 
system. Other Windows operating systems, such as Vista and Windows 7, may require additional 
updates or installations. Please refer to the Microsoft website for necessary details. 

4.3 Evaluation DVD vs. Downloads from Microsoft Website 
The instructions in the following sections are written from the perspective of using the Evaluation 
DVD. It should be assumed that wherever the instruction exists to insert the DVD into your PC, 
you can access the equivalent installation files on the Microsoft Windows Embedded CE website. 

http://www.microsoft.com/windowsembedded/en-us/downloads/default.mspx�
http://www.microsoft.com/windowsembedded/en-us/downloads/default.mspx�
http://www.microsoft.com/windowsembedded/en-us/downloads/default.mspx�
http://www.microsoft.com/windowsembedded/en-us/downloads/default.mspx�
http://www.microsoft.com/windowsembedded/en-us/downloads/default.mspx�
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4.4 Update Windows Operating System 
Before beginning the installation of Visual Studio 2005, Platform Builder, or any Windows CE 6.0 
components, verify that your Windows operating system has all of the most recent updates from 
Microsoft. 

 

4.5 Obtain Product Key(s) 
1. To obtain the Product Key for your Evaluation Kit, go to the URL specified on the sticker on 

the insider of your Evaluation Packet or click on the link to the Microsoft Windows Embedded 
CE website. 

2. Under the Get a Product Key heading, click on the link for Windows Embedded CE. 

3. Sign in with your Windows Live ID or sign up for a Windows Live ID. (NOTE: If you sign-up 
for a Windows Live ID during this step, an email will be sent to you to complete the activation 
process for your Windows Live ID. Complete this activation process before continuing with 
the next step.) 

4. Fill in the online form and click the Continue button at the bottom of the page. 

5. At the completion of the registration process, you will be presented with your Product Key(s) 
and you will also be emailed the Product Key(s). Have these available during the installation 
process below. 

http://www.microsoft.com/windowsembedded/en-us/downloads/default.mspx�
http://www.microsoft.com/windowsembedded/en-us/downloads/default.mspx�
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IMPORTANT NOTE: The emails sent from Microsoft in the steps above may get caught in any 
spam filter(s) associated with your email program. If the emails do not appear in your inbox, be 
sure to check your spam folders. 

4.6 Install Visual Studio 2005 
1. Insert the Visual Studio 2005 DVD into your PC’s DVD drive. 

2. The “Visual Studio 2005 Setup” window will appear. Click on “Install Visual Studio 2005”. 
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3. Visual Studio 2005 will begin loading installation components on your PC. 
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4. When the “Welcome to the Microsoft Visual Studio 2005 installation wizard” window appears, 
click the “Next>” button. 
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5. On the next screen, check the box to accept the terms of the License Agreement. 

6. Enter the product key for your Visual Studio 2005 in the proper fields. 

7. Enter your name in the proper field and then click the “Next>” button. 

 
8. A warning prompt will open reminding you that you are installing a trial edition of Visual 

Studio. Click the “OK” button. 
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9. You will be asked to select which features to install. Select “Default”.  

10. It is recommended to use the default “Product install path”. If this location is not appropriate 
for your PC, click the “Browse…” button and select a different install location. 

11. Click the “Install” button. 
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12. Visual Studio 2005 will begin installing on your PC. This may take quite some time depending 
upon the performance capabilities of your PC. 
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13. You will receive a “Success” notification when the installation process has completed. Click 
the “Finish” button to return to the main “Visual Studio 2005 Setup” window. 
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14. Click “Exit” and remove DVD from your PC. 

 

4.7 Install Visual Studio 2005 Service Pack 1 
1. Insert the “Windows Embedded CE 6.0 R2” DVD into your PC. 

2. A web browser window will open with the contents of the DVD. 
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3. Click on the line that states: “Click Here to Install the Microsoft Visual Studio 2005 Team 
Suite Service Pack 1”. 

 
4. Click the “Save File” button to save the download to your local drive. 

 
5. After the download has completed, locate the .exe file on your local drive and double-click to 

open it. 

6. Click the “OK” button if warned about opening an executable file. 
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7. The service pack update will extract itself and then ask if you want to install “ENU Service 
Pack 1”. Click the “OK” button. 

 
8. A window containing the End User License Agreement (EULA) will appear. Read the EULA 

and click the “I accept” button to continue. 
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9. ENU Service Pack 1 will install on your PC and you will receive a notification when 
installation has completed. Click the “OK” button to close the window. 

 
10. Remove the “Windows Embedded CE 6.0 R2” DVD from your PC’s drive. 

4.8 Install Platform Builder 
This section will describe how to install the Platform Builder Plug-in for Microsoft Visual Studio 
2005. 

1. Insert the DVD named “Windows Embedded CE 6.0” containing the “Platform Builder Plug-in 
for Microsoft Visual Studio 2005” into your PC’s DVD drive. 

2. When the “Welcome to the Windows Embedded CE 6.0 Setup Wizard” window appears, click 
the “Next>” button. 
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3. Enter your name and organization in the appropriate fields. 

4. Enter the product key (obtained in Section 4.5 above) for Windows Embedded CE 6.0 in the 
appropriate fields. 
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5. Read the License Agreement and select “I accept…” if you agree to the terms. Click the 
“Next>” button to continue. 
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6. In the Setup window that appears, select the features that you want installed. By default, the 
“CE 6.0 Tools” (“Windows Embedded CE 6.0 Test Kit” and “Platform Builder”) and the “CE 
6.0 Operating System” for “ARMV4I” are selected. These default features are required for 
development. 

7. Click the “Next>” button. 
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8. If your PC is missing any “Prerequisites” in order to complete the installation, a warning 
window will appear listing the missing components. Once your PC has all the prerequisites, a 
“Ready to Install” window will appear. 

9. Click the “Install” button to begin the installation. 
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10. Windows Embedded CE 6.0 will begin installing on your PC. This may take quite some time 
depending upon the performance capabilities of your PC. 

 
11. Click the “Finish” button to exit Windows Embedded CE 6.0 Setup. 
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12. Remove the “Windows Embedded CE 6.0” DVD from your PC’s drive. 

4.9 Install Platform Builder Service Pack 1 
1. Once again, insert the “Windows Embedded CE 6.0 R2” DVD into your PC’s drive. 

2. A web browser window will open with the contents of the DVD. 

3. Click on the line that states: “Click Here to Install Windows Embedded CE 6.0 Platform 
Builder Service Pack 1”. 

 
4. Click the “Save File” button to save the download to your local drive. 
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5. After the download has completed, locate the .msi file on your local drive and double-click to 
open it. 

6. Click the “Next>” button to continue installation. 
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7. Read the License Agreement and select “I accept…” if you agree to the terms. Click the 
“Next>” button to continue. 

 
8. Click the “Install” button to being installing Platform Builder Service Pack 1. 
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9. When the Service Pack has finished installing, you will see a “Completed” window. Click 
“Finish” to exit the Setup Wizard. 

 

4.9.1 Install the Windows Embedded CE 6.0 R2 Update 

1. Navigate to “My Computer”. Right-click on DVD icon for “CE6R2” and select “Open” from the 
menu. 
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2. Locate the “setup.exe” file and double-click on it. 

 
3. A “Welcome to the Windows Embedded CE 6.0 R2 Setup Wizard” window will appear. Click 

the “Next>” button to continue. 
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4. Read the License Agreement and check “I accept the terms in the License Agreement” if you 
agree to them. Click the “Next>” button to continue the setup process. 

 
5. The Setup program has to determine the disk space requirements on your PC. There is no 

status window for this, so you may receive the following notice when you try to click “Next>”. 
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6. Eventually, the following screen will appear. Keep the defaults set as they are and click the 
“Next>” button. 
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7. Click the “Install” button to being the installation process. 
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8. When the installation has concluded, a “Completed” window will appear. Click the “Finish” 
button to exit the Setup Wizard. 

 

4.9.2 Updated Releases 

Since the publication of this User Manual, additional service packs may have been released from 
Microsoft (e.g., Embedded CE 6.0 R3). Please refer to the Windows CE Development 
Prerequisites.txt file included with the Logic PD Windows CE BSP release to ensure you have the 
latest updates required for that release. Installation steps will be similar to those written in this 
User Manual. 

4.9.3 Use QFE Patches to Update Windows Embedded CE 6.0 

This section will describe how to install Quick Fix Engineering (QFE) patches from Microsoft. 
Installing each QFE patch is a similar process, so we will only document the first patch and you 
can repeat the steps for each required QFE patch. 

4.9.3.1 Download QFE Patches 

1. Return to the web browser window that shows the contents of the DVD and click on the link 
to “Check for Updates”. 
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2. You will be taken to Microsoft’s Download Center website. Because there are several update 

files that will be required from Microsoft’s website, we recommend that you download all of 
the files to your local drive before actually running the updates. The following steps will 
explain the download process. 

3. Locate “Windows Embedded CE 6.0 Cumulative Product Update Rollup Package (through 
12/31/2009)” and click on the link. 
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4. Click on the “Download files below” link. 
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5. Locate the file named “WinCEPB60-091231-Product-Update-Rollup-Armv4I.msi” and click on 
the “Download” button next to the file name. 

 
6. Click “Save File” to download the update file to your local drive. 

 
7. Once that file has finished downloading, use the back button in your web browser to return to 

the Microsoft Download Center page with “Results for – ‘Windows Embedded CE 6.0” 
displayed. 

8. Repeat Steps 3 through 6 until all of the required updates are installed. 

IMPORTANT NOTE: More QFE patches may be required depending on the BSP source you are 
using. Please refer to the Windows CE Development Prerequisites.txt file included with Logic 
PD’s Windows CE source BSP download to see which QFE patches are required. More 
information about Logic PD’s Windows CE source BSP will be covered in the next section of this 
document. 

4.9.3.2 Install the QFE Patches 

1. On your local drive where you saved all the downloads from Microsoft’s website, locate the 
“WinCEPB60-091231-Product-Update-Rollup-Armv4I.msi” file and double-click on it to begin 
installing the Cumulative Product Update Rollup for 2009. 
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2. Click the “Next>” button to continue. 

 
3. Read the License Agreement and check “I accept the terms of the License Agreement” if you 

agree. Click the “Next>” button to continue. 
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4. You will be notified of the source code files that will be overwritten during this installation 
process. Check “I accept” and click the “Next>” button to continue. 

 
5. You will be presented with the option to customize the installation. We recommend you keep 

the defaults set as they are. Click the “Next>” button to continue. 
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6. Click the “Install” button to begin the installation. 
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7. When the installation nears completion, you will see the following window explaining that the 
update has source code files associated with it. (NOTE: This window will often open behind 
the other windows on your desktop. If it appears that the installation process has stalled, see 
if this window is hiding behind the others.) Click the “OK” button and a web browser will open 
showing the associated Readme document. 

 
8. The QFE patch has finished installing when you see the following window. Click the “Finish” 

button to exit the Setup Wizard. 

 
9. Repeat Steps 1 through 8 for each of the remaining QFE patches. 

4.9.4 Verify the QFE Patch Installations 

To verify that you have installed all the necessary QFE patches, you will have to launch the 
Visual Studio 2005 application. 

1. Launch Visual Studio 2005 by going to: Start Menu > All Programs > Microsoft Visual Studio 
2005 > Microsoft Visual Studio 2005 
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2. If this is the first time you’ve launched Visual Studio 2005, you will have to specify your 
default development environment. Click on “Platform Builder Development Settings” and then 
click the “Start Visual Studio” button to continue. 

 
3. When Visual Studio 2005 has started, click on the “Tools” menu heading and select “Platform 

Builder for CE 6.0” and then select “CE Update Check”. 
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4. In the CEUpdateCheck window, click the “Verify Updates” button. 

 
5. CEUpdateCheck will tell you all of the updates that you have installed on your PC compared 

with the updates that have been released to date. 

 
6. Your PC now has all the necessary tools to being Windows CE development. 
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5 Build Logic PD’s Windows CE Source BSP 
This section will describe how to begin Windows CE development with the OMAP35x 
Development Kit. 

5.1 Prerequisites 

■ Tera Term terminal emulator (or equivalent). 

■ The most current Windows CE Source BSP release, as described in Section 2. 

■ Before installing Logic PD’s Windows CE source BSP, please ensure that Visual Studio 2005 
and Windows Embedded CE 6.0 Platform Builder are installed on your PC. This information 
is covered in-depth in the previous section of this User Manual. 

5.2 Install Logic PD’s Windows CE 6.0 Source BSP  
1. Locate the 101xxxx_OMAP35x_WinCE600_x_x_x_Source file you unzipped in Section 2. 

2. Open the Windows CE Development Prerequisites.txt file and verify that you have all the 
QFE patches installed that are required for this release of the source BSP. If you need to 
install new QFE patches, please do so before continuing onto the next step. 

3. Review the logic_som_omap35xx_source_readme.txt file. This contains important 
information that applies to this release of the source BSP. 

4. Copy the contents of the .\PLATFORM\ directory to the x:\WINCE600\PLATFORM\ directory 
of the Windows CE installation. IMPORTANT NOTE: Before copying these contents, delete 
the following two folders (and sub-folders): 

□ C:\WINCE600\PLATFORM\COMMON\SRC\SOC\OMAP35xx_TPS659XX_TI_V1 
□ C:\WINCE600\PLATFORM\LOGIC_SOM_OMAP35x 

5. Copy the contents of the .\OSDesigns\ directory to the x:\WINCE600\OSDesigns\ directory of 
the Windows CE 6.0 installation. IMPORTANT NOTE: Before copying these contents, move 
or delete any pre-existing directories that remain from previous BSP installations if they have 
the same name as the most current release. If an OSDesigns directory does not exist in the 
Windows CE installation directory, create one.  
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5.3 Build Logic PD’s Windows CE 6.0 Source BSP 
1. Launch the Visual Studio 2005 application. Click on File > Open > Project/Solution... 

 
2. Browse to the .\WINCE600\OSDesigns\<OS Design Name>\ directory. 

3. Select the <OS Design Name>.sln file and click the “Open” button. 

4. The following window may appear, if it does please click the “OK” button to continue. 
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5. Choose the correct Platform in the Catalog Item View. NOTE: Select the “Catalog Items 
View” tab to show the list of current catalog items. If the tab is not available, click on View > 
Other Windows > Catalog Items View. The catalog item view displays a “tree” of all features 
that can be added or removed from your custom Windows CE build. 

Make sure to choose the correct platform that you are using (e.g., OMAP35x Torpedo 
Development Kit vs. OMAP35x SOM-LV Development Kit). The radio buttons indicate that 
only one item within that folder may be selected (also indicated by the note to ‘choose one’). 

 
6. To build a solution for the first time in Windows CE 6.0, click on Build > Advanced Build 

Commands > Clean Sysgen. 

7. The build will start and messages from the build system will appear in Visual Studio’s output 
window. NOTE: This can take an hour or longer, depending on your host PC specifications. 
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8. The build has finished when you see Build succeeded in the bottom status window and 
the words build complete in the Output window. 

 

5.3.1 Build Option Use Scenarios 

Build Options Usage 

Sysgen 

Use when Microsoft components have been added or removed 
Selecting new BSP drivers may require additional Microsoft 
components 
Will also build the BSP source files 

Clean Sysgen Also performs a clean prior to Sysgen 
Build and Sysgen Use when any OS source files are modified 
Rebuild and Clean Sysgen Use immediately after installing new QFE package(s) 
Build Current BSP and 
Subprojects 

Use when any BSP source files are modified or BSP registry changes 
have been made 

Rebuild Current BSP and 
Subprojects Also performs a clean prior to "Build Current BSP and Subprojects"  

NOTE: In the menu, click on Build > Global Build Settings. In the window that appears, make 
sure that both Copy Files to Release Directory and Make Run-Time Image options are selected. 

5.4 Run Logic PD’s Windows CE 6.0 Source BSP 
Please follow the steps below to download the newly created Windows Embedded CE image to 
your OMAP35x Development Kit (the steps in this section assumes the download method is via 
Ethernet). 

1. Connect the OMAP35x Development Kit to the Ethernet network. 

2. Connect the OMAP35x Development Kit to your PC using the null-modem serial cable 
included with the kit. 

3. Launch the Tera Term application on your PC. 

4. Power on your OMAP35x Development Kit. 
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5. Initialize LogicLoader’s TCP/IP stack using the ifconfig command. Type  
ifconfig sm0 dhcp and press the Enter key to obtain an IP address from a DHCP server 
on the network. 

 
6. Verify the device received an IP address by typing ifconfig with no parameters and 

pressing the Enter key. Note that the ifconfig command also displays the system MAC 
address. Occasionally, there is a brief delay before a kit obtains an IP address. Please verify 
that your development kit has received a valid IP address before proceeding to the next step. 

 
7. Start the download process by typing bootme & pressing the Enter key. 

The bootme & command sends UDP packets over the LAN to a host PC. The packets are 
recognized by Microsoft Platform Builder as coming from a device waiting to download a 
Windows Embedded CE image. Technically, the command is simply bootme; however, the & 
is needed to launch this command in the background so you may still interact with the 
LogicLoader shell. 
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8. The bootme & command outputs the name that the device will use to communicate with 

Platform Builder and then starts outputting network packets as shown in the figure below. 

 
9. Switch to the Visual Studio 2005 application. Click on Target > Connectivity Options. In the 

window that opens, select Ethernet in the drop-down boxes for both Download and 
Transport. 

10. Click the “Settings” button next to Download. 

 
11. Select the device’s name that LogicLoader output in Step 8 above. It may take several 

seconds for the name to show up in the list of Active target devices. When the name appears, 
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select it and then click the “OK” button. NOTE: The name of your device will almost certainly 
be different than the image below. 

 
12. Click the “Apply” button in the Target Device Connectivity Options window. Then click the 

“Close” button to close the window. 
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13. Click on Target > Attach Device to download the Windows Embedded CE image to the 
OMAP35x Development Kit. 

 
14. Platform Builder will download the new image to the OMAP35x Development Kit. This may 

take some time depending on the network. 

15. When the download is complete, Platform Builder will wait for LogicLoader to connect. 

 
16. Once the image has been transferred, LogicLoader verifies the checksums and then returns 

to the losh> prompt. 
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17. Type exec and press the Enter key. 

 
18. LogicLoader will boot the BSP. The output you see should look similar to the series of 

continuous screenshots presented in the figures below. Depending on the build options, you 
may see additional output; if not, wait for the image to boot and proceed with step 19 below. 
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19. The kit LCD may ask you to calibrate the screen by using a stylus to touch the center of 

several crosshairs. 
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20. Once the screen has been calibrated, tap anywhere on the screen and your OMAP35x 
Development Kit will boot into Windows Embedded CE 6.0. 
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5.5 Enable/Disable Drivers 
The table below provides information on how to enable and disable drivers with the Logic PD 
OMAP35x Windows CE BSP. Implementing any driver changes will require you to perform a 
Build > Advance Build Commands > Rebuild Current BSP and Subproject for the changes to take 
effect; the only exception is for enabling or disabling VFPU Support which requires a clean 
Sysgen (Build > Rebuild Solution). 

This section will show the basics of enabling and disabling a driver in the OMAP35x BSP by 
walking through enabling and disabling the UART driver. Please refer to the individual driver 
documentation (found in the 101xxxx_OMAP35x_WinCE600_x_x_x_Source\Documentation\ 
directory of the source BSP) for more details on using and customizing the OMAP35x 
Development Kit drivers. 

Driver Action Display 
UART Enable Driver: Select catalog item for 

desired UART(S) under Third Party > BSP > 
LOGIC_SOM_OMAP35x: ARMVI > Device 
Drivers > Serial > UART 
 
UART1 
UART2 
UART3 
 
Disable Driver: Deselect catalog item. 
 
 
Note:  In this example, you will see that 
‘UART1’ has a radio button selection for 
either ‘UART1 Debug serial’ or ‘UART1 
Driver (COM1)’. 
 
If you choose ‘UART1 Debug serial’, then 
Windows CE will not have access to 
“COM1:” for serial communication. 
 
If you choose ‘UART1 Driver (COM1)’, then 
Windows CE will have access to UART1 as 
the standard “COM1:” serial port. 
 
Debug serial is used to show debug 
messages from Windows CE and any of its 
drivers or applications that are running. 

 

 

5.6 Customizing Your Windows CE Image 
This section describes how to customize Logic PD’s OMAP35x Windows CE BSP with built-in 
features. 
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5.6.1 Using Onboard Bluetooth 

NOTE: This section only applies to OMAP35x (SOM-LV) Development Kit; the OMAP35x 
Torpedo Development Kit does not support Bluetooth. 

This section will provide an example for how to connect a keyboard and mouse using the onboard 
Bluetooth module.  

Requirements: 

■ This example uses the show image project that is part of the OMAP35x SOM-LV Release. 

■ This section assumes the developer is already familiar with building Logic PD’s Windows CE 
BSP as described at the beginning of Section 5. 

1. Load the show image project file into VS2005. 

2. Open the CATALOG windows in your VS2005 by clicking on View > Other Windows > 
Catalog Items View. 
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3. Add Bluetooth HID Device Support by clicking the checkbox. In this example both Bluetooth 
HID – Keyboard and Bluetooth HID – Mouse have been selected. 

 
4. Verify that the BFR6300 Bluetooth Driver within the BSP is also selected. 
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5. Perform a Build > Build Solution when including Core OS Catalog components. 

NOTE: Whenever a change is made in the Core OS Catalog components, a “Build Solution” 
is required; selecting “Build Current BSP and Subprojects” will not work in this case. 

6. Connect the antenna that comes with your OMAP35x SOM-LV Development kit to the J3 
SMA connector on your OMAP35x SOM-LV Module. 

7. After loading your Windows CE image click on Start > Settings > Control Panel. 

 
8. Double-Click on the Bluetooth Device Properties icon. 
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9. Click on the Scan Device button. 

 
10. On the Bluetooth device you want to connect to your OMAP35x Development Kit, press the 

pairing button. 

11. Once the Bluetooth signal is detected from the device it will appear in the Untrusted window. 
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12. Click the ‘-->’ button to move your Bluetooth device to the Trusted window. In this example, 
the device does not required authentication so click ‘No’. 

 
13. Double-click the Bluetooth device in the Trusted window and select Active to enable the 

device within Windows CE 6.0. 
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14. If the device successfully activates, there will be a red check mark on the device icon as seen 
below. 

 
15. To add another Bluetooth device, follow the instructions above beginning with Step 9. The 

image below shows both a Bluetooth mouse and keyboard successfully enabled. 

 

5.6.2 Using a USB Bluetooth Dongle 

This section will provide an example of how to configure the BSP to use a USB Bluetooth dongle 
and not the onboard Bluetooth module. 

Requirements: 

■ This example uses the show image project that is part of the OMAP35x SOM-LV Release. 

■ This section assumes the developer is already familiar with building Logic PD’s Windows CE 
BSP as described at the beginning of Section 5. 

1. Load the show image project file into VS2005. 
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2. Open the CATALOG windows in your VS2005 by clicking on View > Other Windows > 
Catalog Items View 

 



OMAP35x WinCE 6.0 BSP User Manual 

PN 1016591D Logic PD, Inc. All Rights Reserved. 68 

3. Add Bluetooth HID Device Support by clicking the checkbox. In this example both Bluetooth 
HID – Keyboard and Bluetooth HID – Mouse have been selected. Also select Bluetooth Stack 
with Integrated USB Driver; this is required when using a USB Bluetooth dongle. 
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4. Verify that the BFR6300 Bluetooth Driver within the BSP is not selected; Windows CE 6.0 
only supports one Bluetooth controller at a time. 

 
5. Verify that the appropriate USB Host driver is selected, if applicable. Refer to the driver 

documentation to determine the appropriate drivers to select to enable USB Host support for 
your platform (individual driver documents are located in the 
101xxxx_OMAP35x_WinCE600_x_x_x_Source\Documentation\ directory of the source BSP). 

 



OMAP35x WinCE 6.0 BSP User Manual 

PN 1016591D Logic PD, Inc. All Rights Reserved. 70 

6. Perform a Build > Build Solution when changing Core OS Catalog components. 

7. After the Windows CE image has loaded, connect the USB Bluetooth dongle to the USB Host 
port on the OMAP35x Development Kit. 

8. Select Start > Settings > Control Panel. 

 
9. Double-Click on the Bluetooth Device Properties icon. 
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10. Click on the Scan Device button. 

 
11. On the Bluetooth device you want to connect to your OMAP35x Development Kit, press the 

pairing button. 

12. Once the Bluetooth signal is detected from the device it will appear in the Untrusted window. 
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13. Click the ‘-->’ button to move your Bluetooth device to the Trusted window. In this example, 
the device does not require authentication so select ‘No.’ 

 
14. Double-click the Bluetooth device in the Trusted and select Active to enable the device within 

Windows CE 6.0. 
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15. If the device successfully activates, there will be a red check mark on the device name as 
seen below. 

 
16. To add another Bluetooth device, follow the instructions above beginning with Step 10. The 

image below shows both a Bluetooth mouse and keyboard successfully enabled. 
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