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1 Introduction 
This user guide provides information pertaining to Logic PD’s DM37x Windows Embedded CE 
6.0 Board Support Package (BSP). 

1.1 Nomenclature 
■ This document applies to the DM3730/AM3703 SOM-LV and the 

DM3730/AM3703 Torpedo™ SOM. Use of “DM3730/AM3703 SOM” suggests text that 
applies to both platforms; information specific to one platform will call out the precise 
name.  

■ Use of "DM3730 Development Kit" suggests text that applies to both the 
Zoom™ DM3730 SOM-LV Development Kit and Zoom™ DM3730 Torpedo Development 
Kit; information specific to one development kit will call out the precise name.  

IMPORTANT NOTE: Windows CE software is not supported for use with the 
DM3730/AM3703 Torpedo + Wireless SOM. 

1.2 Note on Images 

The images of screen captures included in this user guide exist as examples of what may 
appear on your host PC display during software installation and use of the BSP; please note 
that version numbers, file names, and other items may differ from the most current release. 

2 Download DM37x Windows Embedded CE 6.0 BSP 

2.1 Prerequisites 
■ DM3730 Development Kit registered on Logic PD’s support site1 

□ Registration is required to grant you access to your product’s download page from 
where the BSP can be downloaded 

■ Host PC 

■ Internet connection 

2.2 Download Steps 
1. Depending on the DM3730 Development Kit you are using, click on the link below to 

point a web browser to the appropriate downloads page. (If you are not already 
logged in, you will need your username and password that was set up during 
registration to access the downloads page.) 

▪ DM3730/AM3703 SOM-LV downloads page2 
▪ DM3730/AM3703 Torpedo downloads page3 

2. Under the Windows CE category, click on DM37x Windows CE 6.0 Source BSP to begin 
the download. 

3. Save the file to your host PC. 

4. After the download completes, locate the 10xxxxx_LogicPD_WinCE6_BSP_x-x-x.zip file 
on your host PC. 

5. Extract the file to a directory of your choice. 

                                                
1 http://support.logicpd.com/TechnicalSupport/RegisterProduct.aspx 
2 http://support.logicpd.com/ProductDownloads/DM3730AM3703SOM-LV.aspx 
3 http://support.logicpd.com/ProductDownloads/DM3730AM3703TorpedoSOM.aspx 

http://support.logicpd.com/TechnicalSupport/RegisterProduct.aspx
http://support.logicpd.com/ProductDownloads/DM3730AM3703SOM-LV.aspx
http://support.logicpd.com/ProductDownloads/DM3730AM3703TorpedoSOM.aspx
http://support.logicpd.com/TechnicalSupport/RegisterProduct.aspx
http://support.logicpd.com/ProductDownloads/DM3730AM3703SOM-LV.aspx
http://support.logicpd.com/ProductDownloads/DM3730AM3703TorpedoSOM.aspx
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6. After the extraction is complete, visually verify that the following sub-directories and 
files have been created: 

.\Binaries  
 \<OS Design Name> 

\<Platform Name> 
\several NK.bin files 

\LogicLoader_Scripts 
.\Documentation 

Driver Description documents for specific 
components 

 Feature Matrix 
.\OSDesigns 
 \<OS Design Name> 
.\PLATFORM 
 \COMMON\SRC\SOC\<SOC Name> 
  Several subfolders and files 
 \<Platform Name> 
  Several subfolders and files 
.\Test_Docs 
 
LogicPD_WinCE6_BSP_x-x-x_Release_Notes.txt 
Windows CE Development Prerequisites.txt 

7. Take special note of the two text files at the root level: LogicPD_WinCE6_BSP_x-x-
x_Release_Notes.txt and Windows CE Development Prerequisites.txt. Both of these 
files will be referenced later in this user guide. 

2.3 Next Steps 

From this point, you can continue through this user guide in order or, based on the following 
descriptions, you can jump to the section that is most appropriate for your use. 

■ Section 3 describes how to use the pre-built NK.bin binary files (included in the BSP 
download) to evaluate the BSP on the DM3730 Development Kit. These NK.bin files 
are loaded to the DM3730 Development Kit via an external source (SD card, 
CompactFlash (CF) card, or Ethernet). 

■ Section 4 explains how to install the evaluation version of Windows Embedded CE 6.0 
on your host PC, including Visual Studio 2005 and Platform Builder. If you already 
have these programs installed on your PC, you can skip this section. 

■ Section 5 describes how to begin Windows CE development using Logic PD’s BSP and 
DM3730 Development Kit. Visual Studio 2005 and Platform Builder must be installed 
on your host PC before proceeding to this section. 
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3 Sample Pre-Built Images 
This section describes how to load a Windows CE pre-built image (NK.bin) on the 
DM3730 Development Kit using three different methods: SD card, CF card, and Ethernet. 

Sample NK.bin binary files allow you to evaluate Logic PD's BSP on the DM3730 Development 
Kit. They are also useful for application development since each image includes helpful 
libraries and a variety of drivers. Logic PD’s sample NK.bin images are not meant for 
production and should not be regarded as production-ready. 

3.1 Prerequisites 
■ Tera Term terminal emulator (or equivalent) 

■ The most current Windows CE Source BSP release, as described in Section 2 

■ An SD card or CF card with a capacity of at least 32 MB—this card must be large 
enough to store the sample NK.bin file 

■ An Ethernet cross-over cable 

3.2 Load Pre-Built Image via SD Card 

This section describes how to load the NK.bin image from an SD card using LogicLoader and 
then boot the image. 

1. Locate the 10xxxxx_LogicPD_WinCE6_BSP_x-x-x.zip file that you extracted in 
Section 2. 

2. Read through the LogicPD_WinCE6_BSP_x-x-x_Release_Notes.txt to learn of any 
dependencies specific to the most current release. 

3. Navigate to the .\Binaries\<OS Design Name>\ directory and you will find several 
NK.bin files. 

4. Copy the <SOM_Type>_NK.bin file from that directory to an SD card. (Make sure to 
copy the appropriate file for your DM3730 Development Kit.) 

5. Insert the SD card into the DM3730 Development Kit’s SD card slot. NOTE: For the 
DM3730 Torpedo™ Development Kit, use the primary SD card slot (J21) located closer 
to the middle of the baseboard edge.  

6. Verify the DM3730 Development Kit is connected to the host PC via a serial cable and 
is connected to the power supply. (Detailed instructions for these connections can be 
found in the respective DM3730 Development Kit User Guides.) 

7. Launch Tera Term on your host PC. 

8. In Tera Term, select Setup > Serial port... from the menu bar.  

9. Select the appropriate COM port for your host PC and then change the port settings 
to:  

a. Baud rate:115200 
b. Data: 8 bit 
c. Parity: none 
d. Stop: 1 bit  
e. Flow control: none 



DM37x Windows Embedded CE 6.0 BSP User Guide 

PN 1020100C Logic PD, Inc. All Rights Reserved. 4 

 

Figure 3.1: Tera Term Serial Port Settings 

10. Click OK.  

11. Power on the DM3730 Development Kit and verify the LogicLoader prompt appears in 
the terminal emulator window. 

12. Mount the SD card in LogicLoader. 

 
losh> mount fatfs /dev/sdmmc0a /sd 
 

13. Change directories to the SD card. 

 
losh> cd /sd 
 

14. List the contents of your SD card and confirm the <SOM_Type>_NK.bin file is on the 
card. 

 
losh> ls 
      :                    SOM-LV_NK.bin 28032595 
 

15. Load the NK.bin file into RAM with the command below. Be sure to insert the 
appropriate name of the file you are using.  

NOTE: LogicLoader is case sensitive, so be sure to type the filename the same way it 
appears in LogicLoader after using the ls command. 

 
losh> load bin <SOM_Type>_NK.BIN  
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You should see the following output, indicating your NK.bin file was successfully loaded 
into system RAM and is ready to boot:  

 
.......................................................................
.......................................................................
....................................................................... 
.......................................................................
.......................................................................
.......................................................................
....................................... 
image launch addr: 0x8120a0e0 
 
Verifying checksums: >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> 
Checksums good. 
file loaded 
losh> 
 

NOTE: The sample NK.bin images provided on Logic PD’s website run from system 
RAM and cannot be burned to system flash. Since the sample NK.bin images are 
volatile, they need to be loaded from an external source (like an SD card) after every 
power cycle. 

16. Boot the NK.bin file.  

 
losh > exec 
 

Immediately, the kit LCD should turn on. In Tera Term, you will see a message stating 
Starting Kernel... and then other output messages. 

17. After allowing time for the image to boot, the kit LCD may prompt you to calibrate the 
touchscreen by pressing a stylus to the center of cross-hairs on the screen. If 
necessary, follow the onscreen instructions and the NK.bin file will boot and display 
the Windows Embedded CE 6.0 graphical user interface (GUI) on the kit LCD. 
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3.3 Load Pre-Built Image via CF Card 

NOTE: This section only applies to the DM3730 SOM-LV Development Kit; the 
DM3730 Torpedo™ Development Kit does not have a CF card slot. 

The process for loading a sample image via CF card is very similar to the SD card.  

1. Locate the 10xxxxx_LogicPD_WinCE6_BSP_x-x-x.zip file that you extracted in 
Section 2. 

2. Read through the LogicPD_WinCE6_BSP_x-x-x_Release_Notes.txt file to learn of any 
dependencies specific to the most current release. 

3. Navigate to the .\Binaries\<OS Design Name>\ directory and you will find several 
NK.bin files. 

4. Copy the SOM_LV_NK.bin file from that directory to a CF card. 

5. Insert the CF card into the DM3730 SOM-LV Development Kit’s CF card slot. 

6. Verify the DM3730 SOM-LV Development Kit is connected to the host PC via a serial 
cable and is connected to the power supply. (Detailed instructions for these 
connections can be found in the DM3730 SOM-LV Development Kit User Guide.4) 

7. Launch Tera Term on the host PC. 

8. In Tera Term, select Setup > Serial port... from the menu bar.  

9. Select the appropriate COM port for your host PC and then change the port settings 
to:  

a. Baud rate:115200 
b. Data: 8 bit 
c. Parity: none 
d. Stop: 1 bit  
e. Flow control: none 

 

Figure 3.2: Tera Term Serial Port Settings 

10. Click OK.  

                                                
4 http://support.logicpd.com/DesktopModules/Bring2mind/DMX/Download.aspx?portalid=0&EntryId=715 

http://support.logicpd.com/DesktopModules/Bring2mind/DMX/Download.aspx?portalid=0&EntryId=715
http://support.logicpd.com/DesktopModules/Bring2mind/DMX/Download.aspx?portalid=0&EntryId=715
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11. Power on the DM3730 SOM-LV Development Kit and verify the LogicLoader prompt 
appears in the terminal emulator window. 

12. Mount the CF card in LogicLoader. 

 
losh> mount fatfs /dev/ata0a /cf 
 

13. Change the directory to the CF card.  

 
losh> cd /cf  
 

14. List the contents of your CF card and confirm the SOM_LV_NK.bin file is on the card. 

 
losh> ls 
      :                  SOM_LV_NK.bin 28032595 
losh> 
 

15. Load the SOM_LV_NK.bin file into RAM.  

NOTE: LogicLoader is case sensitive, so be sure to type the filename the same way it 
appears in LogicLoader after using the ls command. 

 
losh> load bin SOM_LV_NK.BIN 
 

You should see the following output, indicating your NK.bin file was successfully loaded 
into system RAM and is ready to boot: 

 
.......................................................................
.......................................................................
.......................................................................
.......................................................................
.......................................................................
.......................................................................
....................................... 
image launch addr: 0x8120a0e0 
 
Verifying checksums: >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> 
Checksums good. 
file loaded 
losh> 
 

NOTE: The sample NK.bin images provided on Logic PD’s website run from system 
RAM and cannot be burned to system flash. Since the sample NK.bin images are 
volatile, they need to be loaded from an external source (like an SD card) after every 
power cycle. 
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16. Boot the NK.bin file. 

 
losh> exec 
 

Immediately, the kit LCD should turn on. In Tera Term, you will see a message stating 
Starting Kernel... and then other output messages. 

17. After allowing time for the image to boot, the kit LCD may prompt you to calibrate the 
touchscreen by pressing a stylus to the center of cross-hairs on the screen. If 
necessary, follow the onscreen instructions and the NK.bin file will boot and display 
the Windows Embedded CE 6.0 graphical user interface (GUI) on the kit LCD. 

 

3.4 Load Pre-Built Image via Ethernet 

This section describes how to download the OS image via Ethernet in LogicLoader. It is 
assumed that a TFTP program has been installed on your host PC. 

1. Place the <SOM_TYPE>_NK.bin file in your TFTP folder. 

2. Launch your TFTP program. 
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3. Start Tera Term and initialize the Ethernet port.  

 
losh> ifconfig  
 
sm0: up    100M full-duplex  (25) 
sm0:      mac: 00:08:ee:02:38:79  ip: 0.0.0.0 
         mask: 0.0.0.0   gw: 0.0.0.0 
 

4. Start DHCP.  

 
losh> ifconfig sm0 dhcp  
Starting DHCP on sm0. 
 

5. Finally, use ifconfig again to obtain an IP address. 

 
losh> ifconfig 
 
sm0: up    100M full-duplex  (25) 
sm0:      mac: 00:08:ee:02:38:79  ip: 10.0.5.119 
         mask: 255.255.252.0      gw: 10.0.4.1 
 

6. Load the NK.bin file with the command below. Be sure to insert the IP address for your 
system and the appropriate name of the file you are using. 

 
losh> load bin /tftp/<x.x.x.x>:<SOM_TYPE>_NK.bin 
loading from /tftp/10.0.5.101:NK_release.bin: 
R 
.......................................................................
.......................................................................
.......................................................................
.......................................................................
................................. 
image launch addr: 0x801094b8 
 
Verifying checksums: >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>> 
Checksums good. 
...done 
file loaded 
losh>  
 

7. Boot the NK.bin file. 

 
losh> exec 
Windows CE Kernel for ARM (Thumb Enabled) Built on Feb 5 2008 at 
10:48:36 
PlatfromInit: DONE!!! 
---High Performance Frequency is 32768 khz--- 
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8. After allowing time for the image to boot, the kit LCD may prompt you to calibrate the 
touchscreen by pressing a stylus to the center of cross-hairs on the screen. If 
necessary, follow the onscreen instructions and the NK.bin file will boot and display 
the Windows Embedded CE 6.0 graphical user interface (GUI) on the kit LCD. 

 

3.5 Recreate Bootable SD Card Demo Image 

This section will explain how to build a bootable SD card that contains the same files as those 
on the DM37x Windows Embedded CE 6.0 Demo SD card included in the DM3730 
Development Kit.  

3.5.1 Prerequisites 

To execute the procedures in this section, you will need to download the following files from 
the Logic PD website:  

■ DM37x Windows Embedded CE 6.0 SD Card Demo Image5 
■ HP USB Disk Storage Format Tool v2.0.66 

3.5.2 Procedure 

1. Launch the HP USB Disk Storage Format Tool v2.0.6.  

                                                
5 http://support.logicpd.com/DesktopModules/Bring2mind/DMX/Download.aspx?portalid=0&EntryId=2666 
6 http://support.logicpd.com/DesktopModules/Bring2mind/DMX/Download.aspx?portalid=0&EntryId=2760 

http://support.logicpd.com/DesktopModules/Bring2mind/DMX/Download.aspx?portalid=0&EntryId=2666
http://support.logicpd.com/DesktopModules/Bring2mind/DMX/Download.aspx?portalid=0&EntryId=2760
http://support.logicpd.com/DesktopModules/Bring2mind/DMX/Download.aspx?portalid=0&EntryId=2666
http://support.logicpd.com/DesktopModules/Bring2mind/DMX/Download.aspx?portalid=0&EntryId=2760
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2. In the window that appears:  

a. Select your SD card drive from the Device drop-down menu.  
b. Select FAT in the File System drop-down menu.  
c. Add a description to the Volume label field to help you identify the card later. 
d. Select the checkbox labeled "Quick Format." 

 

3. Double check that you have selected the correct device for the format operation. The 
next step will remove everything from the selected device and is not reversible. 

4. Click Start to begin the format process. 

5. You will receive a warning that the data will be lost on the device you have selected. 
Use this opportunity to once again ensure the correct drive has been selected. 

 

6. When the format operation is complete, copy the MLO file from the DM37x Windows 
Embedded CE 6.0 SD Card Demo Image download to the new SD card. 

7. Then copy the remaining files from the download to the SD card. 

The SD card can now boot the Windows CE demo image on the DM3730 Development Kit. 
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4 Prepare for Windows CE Development 
This section describes the steps required to prepare your host PC for Windows CE 
development. 

4.1 Prerequisites 
■ Host PC with DVD drive (DVD drive only required if using the Windows Embedded CE 

6.0 180-Day Evaluation Kit DVD)  

■ Current version of Internet Explorer, Firefox, or other web browser and access to the 
Internet 

■ Windows Embedded CE 6.0 180-Day Evaluation Kit DVD included with your DM3730 
Development Kit or equivalent downloads from the Microsoft Windows Embedded CE 
website7 

■ Windows CE Development Prerequisites.txt file included with the Logic PD 
DM37x Windows Embedded CE 6.0 BSP release 

4.2 Installation Overview 

This section will walk you through the recommended installation steps for Visual Studio 2005 
and Platform Builder. The following is a high-level look at the installation process: 

1. Update your PC using Windows Update. 

2. Install Visual Studio 2005 from the Windows Embedded CE 6.0 180-Day Evaluation Kit 
provided with the DM3730 Development Kit or from the Microsoft Windows Embedded 
CE website.  

3. Update Visual Studio from the Windows Update website, which includes the Visual 
Studio 2005 Service Pack 1. 

4. Install Platform Builder from the Evaluation Packet. 

5. Update Platform Builder.  

NOTE: Different versions of Logic PD’s Windows CE BSP may require specific Microsoft 
Platform Builder updates. Since Microsoft releases monthly patches to Windows CE, 
please refer to the Windows CE Development Prerequisites.txt file to determine which 
updates pertain to your BSP version. This text file is located in the base directory of 
the Logic PD Windows CE BSP source package. 

6. Run Visual Studio 2005. 

7. Run the QFE Check tool from Visual Studio 2005 

IMPORTANT NOTE: This document is written assuming the use of the Windows XP operating 
system (OS). Other Windows OSs, such as Vista and Windows 7, may require additional 
updates or installations. Please refer to the Microsoft website for necessary details. 

4.3 Evaluation DVD vs. Downloads from Microsoft Website 

The instructions in the following sections are written from the perspective of using the 
Evaluation DVD. It should be assumed that wherever the instruction exists to insert the DVD 
into your host PC, you can access the equivalent installation files on the Microsoft Windows 
Embedded CE website.  

                                                
7 http://www.microsoft.com/windowsembedded/en-us/downloads/default.mspx  

http://www.microsoft.com/windowsembedded/en-us/downloads/default.mspx
http://www.microsoft.com/windowsembedded/en-us/downloads/default.mspx
http://www.microsoft.com/windowsembedded/en-us/downloads/default.mspx
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4.4 Update Windows OS 

Before beginning the installation of Visual Studio 2005, Platform Builder, or any 
Windows CE 6.0 components, verify that your Windows OS has all of the most recent updates 
from Microsoft. 

 

4.5 Obtain Product Key(s) 

Microsoft has discontinued the distribution of evaluation keys for Windows Embedded CE 6.0 
on their website. If you do not already have product keys for Windows Embedded CE 6.0 and 
Visual Studio 2005 use the keys below. 

Windows Embedded CE 6.0 (plug-in for Visual Studio 2005):  

H8RQR-MMKRP-XFRFC-9HKGJ-82R6J 

Visual Studio 2005, Visual Studio 2005 Professional Edition Trial: 

M3C9X-9K3Q9-DC8PX-B3YR3-BKQR8 

These keys have been approved for distribution by Microsoft for the demo versions of the 
associated products. 
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4.6 Install Visual Studio 2005 
1. Insert the Visual Studio 2005 DVD into your host PC’s DVD drive. 

2. The Visual Studio 2005 Setup window will appear. Click the Install Visual Studio 2005 
link. 

 

Visual Studio 2005 will begin loading installation components on your host PC. 
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3. When the installation wizard window appears, click Next. 

 

4. On the next screen, select the checkbox labeled "I accept the terms of the License 
Agreement." 

5. Enter the product key for your Visual Studio 2005 in the Product Key: field. 
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6. Enter your name in the Name: field and then click Next. 

 

7. A warning prompt will open reminding you that you are installing a trial edition of 
Visual Studio. Click OK. 
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8. You will be asked to select which features to install.  

a. Select the radio button labeled “Default.” 

b. It is recommended to use the default “Product install path”. If this location is not 
appropriate for your host PC, click Browse… and select a different install location. 

c. Click Install. 
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9. Visual Studio 2005 will begin installing on your host PC. This may take quite some 
time depending upon the performance capabilities of your host PC. 
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10. You will receive a Success - Visual Studio Setup is complete notification when the 
installation process has completed. Click Finish to return to the main Visual Studio 
2005 Setup window. 

 

11. Click Exit and remove the DVD from your host PC. 
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4.7 Install Visual Studio 2005 Service Pack 1 
1. Insert the Windows Embedded CE 6.0 R2 DVD into your host PC. 

2. A web browser will open with the contents of the DVD. 

3. Click on the line that states: Click Here to Install the Microsoft Visual Studio 2005 
Team Suite Service Pack 1. 

 

4. Click Save File to save the download to your local drive. 

 

5. After the download is complete, locate the .exe file on your local drive and double-click 
to open it. 

6. Click OK when warned about opening an executable file. 

 



DM37x Windows Embedded CE 6.0 BSP User Guide 

PN 1020100C Logic PD, Inc. All Rights Reserved. 21 

7. Click OK when asked if you want to install the ENU Service Pack 1.  

 

8. A window containing the End User License Agreement (EULA) will appear. Read the 
EULA and click "I accept" to continue. 

 

9. The ENU Service Pack 1 will install on your host PC and you will receive a notification 
when installation is complete. Click OK. 
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10. Remove the Windows Embedded CE 6.0 R2 DVD from your host PC. 

4.8 Install Platform Builder 

This section will describe how to install the Platform Builder Plug-in for Microsoft Visual Studio 
2005. 

1. Insert the Windows Embedded CE 6.0 DVD into your host PC that contains the 
Platform Builder Plug-in for Microsoft Visual Studio 2005. 

2. When the Windows Embedded CE 6.0 Setup window appears, click Next. 
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3. In the Customer Information window, enter your name, organization, and product key 
(obtained in Section 4.5 above) for Windows Embedded CE 6.0 in the appropriate 
fields. 

 

4. Read the License Agreement and select the radio button labeled “I accept...” if you 
agree to the terms. Click Next. 
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5. In the Setup window that appears, select the features that you want installed. By 
default, the CE 6.0 Tools (Windows Embedded CE 6.0 Test Kit and Platform Builder) 
and the CE 6.0 Operating System for ARMV4I are selected. These default features are 
required for development. 

 

6. Click Next. 
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7. If your host PC is missing any prerequisites in order to complete the installation, a 
warning window will appear listing the missing components. Once your host PC has 
everything that is required, a Ready to Install window will appear. Click Install. 

 

8. Windows Embedded CE 6.0 will begin installing. This may take quite some time 
depending upon the performance capabilities of your host PC. 
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9. When the setup is complete, click Finish. 

 

10. Remove the Windows Embedded CE 6.0 DVD from host PC. 
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4.9 Install Platform Builder Service Pack 1 
1. Once again, insert the Windows Embedded CE 6.0 R2 DVD into your host PC. A web 

browser will open with the contents of the DVD. 

2. Click on the line that states: Click Here to Install Windows Embedded CE 6.0 Platform 
Builder Service Pack 1. 

 

3. Click Save File to save the download to your local drive. 

 

4. After the download is complete, locate the .msi file on your local drive and double-click 
to open it. 
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5. When the Windows Embedded CE 6.0 Platform Builder Service Pack 1 Setup window 
appears, click Next. 

 

6. Read the License Agreement and select the radio button labeled “I accept…” if you 
agree to the terms. Click Next. 
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7. Click Install to being installing Platform Builder Service Pack 1. 

 

8. When installation is complete, click Finish. 
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4.9.1 Install Windows Embedded CE 6.0 R2 Update 

1. Navigate to My Computer. Right-click the CE6R2 DVD icon and select Open from the 
menu. 

 

2. Locate the setup.exe file and double-click it. 
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3. A Windows Embedded CE 6.0 R2 Setup window will appear. Click Next. 

 

4. Read the License Agreement and select the radio button labeled “I accept...” if you 
agree to the terms. Click Next. 
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5. The setup program has to determine the disk space requirements on your host PC. 
There is no status window for this, so you may receive the following notice if you click 
Next again. 

 

6. Eventually, the Setup window will appear. Keep the default settings and click Next. 

 



DM37x Windows Embedded CE 6.0 BSP User Guide 

PN 1020100C Logic PD, Inc. All Rights Reserved. 33 

7. Click Install. 

 

8. When installation is complete, click Finish. 
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4.9.2 Updated Releases 

Since the publication of this user guide, additional service packs may have been released from 
Microsoft (e.g., Embedded CE 6.0 R3). Please refer to the Windows CE Development 
Prerequisites.txt file included with the Logic PD Windows CE BSP release to ensure you have 
the latest updates required for that release. Installation steps will be similar to those found in 
this user guide. 

4.9.3 Use QFE Patches to Update Windows Embedded CE 6.0 

This section will describe how to install Quick Fix Engineering (QFE) patches from Microsoft. 
Installing each QFE patch is a similar process, so we will only document the first patch and you 
can repeat the steps for each required QFE patch. 

4.9.3.1 Download QFE Patches 

1. Return to the web browser that shows the contents of the DVD and click the link to 
Check for Updates at the bottom of the page. 

 



DM37x Windows Embedded CE 6.0 BSP User Guide 

PN 1020100C Logic PD, Inc. All Rights Reserved. 35 

You will be taken to Microsoft’s Download Center website. Because there are several 
update files that will be required from Microsoft’s website, we recommend that you 
download all of the files to your local drive before actually running the updates. The 
following steps will explain the download process. 

2. Locate the Windows Embedded CE 6.0 Cumulative Product Update Rollup Package 
(through 12/31/2009) link and click on it. 
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3. Click the Download files below link. 

 

4. Locate the WinCEPB60-091231-Product-Update-Rollup-Armv4I.msi file and click the 
Download button next to the file name. 
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5. Click Save File to download the update file to your local drive. 

 

6. Once that file has finished downloading, use the back button in your web browser to 
return to the Microsoft Download Center page with “Results for – ‘Windows Embedded 
CE 6.0” displayed. 

7. Repeat Steps 2 through 5 until all of the required updates are installed. 

IMPORTANT NOTE: More QFE patches may be required depending on the BSP source you are 
using. Please refer to the Windows CE Development Prerequisites.txt file included with 
Logic PD’s Windows CE source BSP download to see which QFE patches are required. More 
information about Logic PD’s Windows CE source BSP will be covered in the next section of this 
document. 

4.9.3.2 Install QFE Patches 

1. On your local drive where you saved the downloads from Microsoft’s website, locate 
the WinCEPB60-091231-Product-Update-Rollup-Armv4I.msi file and double-click it to 
begin installing the Cumulative Product Update Rollup for 2009. 

2. When the WinCEB60-071231-Product-Update_Rollup-Armv41 Setup window appears, 
click Next. 
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3. Read the License Agreement and select the radio button labeled “I accept...” if you 
agree to the terms. Click Next. 

 

4. You will be notified of the source code files that will be overwritten during the 
installation process. Select the radio button labeled “I accept” and click Next to 
continue. 
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5. You will be presented with the option to customize the installation. We recommend 
you keep the default settings and click Next. 

 

6. Click Install. 
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7. When the installation nears completion, you will see the following window explaining 
that the update has source code files associated with it. (NOTE: This window will often 
open behind the other windows on your desktop. If it appears that the installation 
process has stalled, see if this window is hiding behind the others.) Click OK and a web 
browser will open showing the associated Readme document. 

 

8. When installation is complete, click Finish. 

 

9. Repeat Steps 1 through 8 for each of the remaining QFE patches. 

4.9.4 Verify the QFE Patch Installations 

To verify that you have installed all the necessary QFE patches, you will have to launch the 
Visual Studio 2005 application. 

1. Launch Visual Studio 2005 by selecting Start Menu > All Programs > Microsoft Visual 
Studio 2005 > Microsoft Visual Studio 2005. 
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2. If this is the first time you’ve launched Visual Studio 2005, you will have to specify 
your default development environment. Select Platform Builder Development Settings 
from the drop-down menu and click the Start Visual Studio button to continue. 

 

3. In Visual Studio 2005, select Tools > Platform Builder for CE 6.0 > CE Update Check. 
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4. In the CEUpdateCheck window, click Verify Updates. 

 

5. CEUpdateCheck will compare all of the updates that you have installed on your host PC 
against the updates that have been released to date. 

 

Your host PC now has all the necessary tools to begin Windows CE development. 
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5 Prepare for Windows CE Application Development 
This section describes the steps required to set up your host PC for Windows CE applications 
development using the DM37x Linux BSP. Application developers will need the SDK created in 
this section to develop applications that communicate with the BSP. 

5.1 Prerequisites  
■ Host PC with DVD drive (DVD drive only required if using the Windows Embedded CE 

6.0 180-Day Evaluation Kit DVD)  

■ Current version of Internet Explorer, Firefox, or other web browser and access to the 
Internet 

■ Windows Embedded CE 6.0 180-Day Evaluation Kit DVD included with your 
DM3730 Development Kit or equivalent downloads from the Microsoft Windows 
Embedded CE website8 

■ Windows CE Development Prerequisites.txt file included with the Logic PD 
DM37x Windows Embedded CE 6.0 BSP release 

5.2 Create & Install SDK 
1. In Visual Studio 2005, select Project > Add New SDK.  

2. Fill in the SDK property information as shown below. Click OK. 

 

                                                
8 http://www.microsoft.com/windowsembedded/en-us/downloads/default.mspx  

http://www.microsoft.com/windowsembedded/en-us/downloads/default.mspx
http://www.microsoft.com/windowsembedded/en-us/downloads/default.mspx
http://www.microsoft.com/windowsembedded/en-us/downloads/default.mspx
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3. Right-click LogicPD DM37x Family SDK 3.0.1 in the Solution Explorer window and 
select Build. Wait for the SDK build to complete. 

 

You should see the output below; note the location of the SDK in the output. If 
Platform Builder failed to generate the install file, please see Section 5.2.1.  

 

4. Navigate to 
C:\WINCE600\OSDesigns\LOGIC_SOM_ARM_A8\LOGIC_SOM_ARM_A8\SDKs\SDK1\M
SI and double-click SDK1.msi to begin installation. 
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5.2.1 SDK Does not Build Properly 

When building the SDK, Platform Builder may generate the following warning: 

 

In this case, you will need to generate a 32-bit wrapper application to execute the gensdk.exe 
with the correct registry configuration. Follow "Step 7: PBXMLUtils" from this Installing 
Windows CE 6.0 Tools wiki article9 to create a wrapper application. 

You will now need to use the Platform Builder command line to build the SDK.  

1. In Visual Studio 2005, select Build > Open Release Directory in Build Window. 

 

2. Enter the following commands to build your SDK: 

 
"C:\Program Files (x86)\Microsoft Platform 
Builder\6.00\cepb\IdeVS\GenSdk32.exe" 
"C:\WINCE600\OSDesigns\LOGIC_SOM_ARM_A8\LOGIC_SOM_ARM_A8\SDKs\SDK1\obj\
BuildSDK1.xml" 
 

5.3 Use Remote Registry Viewer 

As an example of using the SDK, this section explains how to connect to the 
DM3730 Development Kit using the SDK to view and edit the registry on the kit. 

1. Connect a USB OTG cable to the USB OTG port on the DM3730 Development Kit and 
to the host PC. 

                                                
9 http://geekswithblogs.net/WindowsEmbeddedCookbook/archive/2010/08/31/installing-windows-ce-6.0-tools-on-a-
windows7-64bit-pc.aspx 

http://geekswithblogs.net/WindowsEmbeddedCookbook/archive/2010/08/31/installing-windows-ce-6.0-tools-on-a-windows7-64bit-pc.aspx
http://geekswithblogs.net/WindowsEmbeddedCookbook/archive/2010/08/31/installing-windows-ce-6.0-tools-on-a-windows7-64bit-pc.aspx
http://geekswithblogs.net/WindowsEmbeddedCookbook/archive/2010/08/31/installing-windows-ce-6.0-tools-on-a-windows7-64bit-pc.aspx
http://geekswithblogs.net/WindowsEmbeddedCookbook/archive/2010/08/31/installing-windows-ce-6.0-tools-on-a-windows7-64bit-pc.aspx
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2. Complete the installation of any ActiveSync drivers. You should be able to browse the 
files on the remote device using ActiveSync. 

3. To start the Windows CE Remote Registry Editor, select Start > All Programs > 
Microsoft Visual Studio 2005 > Visual Studio Remote Tools > Remote Registry Editor. 

4. When the Select a Windows CE Device window appears, select LogicPD DM37x Family 
SDK 3.0.1 ARMV4I and click "OK." The Remote Registry Editor will download several 
files to the DM3730 Development Kit and display the registry. 

5. If the connection failed, select Target > Connectivity Options > LogicPD DM37x Family 
SDK 3.0.1 ARMV4I Device in the Windows CE Remote Registry Editor window. 

6. Click the "Properties" button and make the following changes:  

a. In the Transport: field, ensure TCP Connect Transport is selected.  
b. In the Startup Server: field, ensure ActiveSync Startup Provider is selected. 
c. Click Test to verify your settings. Click OK to save them. 

 

7. In the main Windows CE Remote Registry Editor window, select Target > Connect to 
start your connection. 
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6 Build Logic PD’s Windows Embedded CE 6.0 BSP 
This section will describe how to begin Windows CE development with the DM3730 
Development Kit. 

6.1 Prerequisites 
■ Tera Term terminal emulator (or equivalent) 

■ Before installing Logic PD’s Windows Embedded CE 6.0 BSP source, please ensure that 
Visual Studio 2005 and Windows Embedded CE 6.0 Platform Builder are installed on 
your host PC. This information is covered in-depth in Section 4. 

■ The most current Windows Embedded CE 6.0 BSP release, as described in Section 2 

6.2 Install Logic PD’s Windows Embedded CE 6.0 BSP  
1. Locate the 10xxxxx_LogicPD_WinCE6_BSP_x-x-x.zip file you extracted in Section 2. 

2. Open the Windows CE Development Prerequisites.txt file and verify that you have all the 
QFE patches installed that are required for this release of the source BSP. If you need 
to install new QFE patches, please do so before continuing. 

3. Review the LogicPD_WinCE6_BSP_x-x-x_Release_Notes.txt file. This contains 
important information that applies to this release of the source BSP. 

4. Copy the contents of the .\PLATFORM\ directory to the x:\WINCE600\PLATFORM\ 
directory of the Windows CE installation. IMPORTANT NOTE: Before copying these 
contents, delete the following two folders (and sub-folders): 

▪ C:\WINCE600\PLATFORM\COMMON\SRC\SOC\DM37x_TPS659XX_TI_V1 
▪ C:\WINCE600\PLATFORM\LOGIC_SOM_DM37x 

5. Copy the contents of the .\OSDesigns\ directory to the x:\WINCE600\OSDesigns\ 
directory of the Windows CE 6.0 installation. IMPORTANT NOTE: Before copying 
these contents, move or delete any pre-existing directories that remain from previous 
BSP installations if they have the same name as the most current release. If an 
OSDesigns directory does not exist in the Windows CE installation directory, create 
one.  

6.3 Build Logic PD’s Windows Embedded CE 6.0 BSP 
1. Launch Visual Studio 2005. Select File > Open > Project/Solution.... 
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2. Browse to the .\WINCE600\OSDesigns\<OS Design Name>\ directory. 

3. Select the <OS Design Name>.sln file and click "Open." 

4. The following window may appear; click OK to continue. 

 

5. Select View > Other Windows > Catalog Items View to show the list of current catalog 
items. The Catalog Items View window displays a “tree” of all features that can be 
added or removed from your custom Windows CE build. 

6. In the Catalog Items View window, select the radio button for the platform you are 
using (i.e., DM3730/AM3703 SOM-LV or DM3730/AM3703 Torpedo™ SOM).  

 

7. To build a solution for the first time in Windows CE 6.0, select Build > Advanced Build 
Commands > Clean Sysgen. 
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8. The following window may appear; click OK to continue. 

 

The build will start and messages from the build system will appear in Visual Studio’s 
output window. NOTE: This can take an hour or longer, depending on your host PC 
specifications. 

9. The build has finished when you see a Build succeeded message in the status window. 
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6.3.1 Build Option Use Scenarios 

Build Options Usage 

Sysgen 

Use when Microsoft components have been added or removed 

Selecting new BSP drivers may require additional Microsoft 
components 

Will also build the BSP source files 

Clean Sysgen Performs a clean prior to Sysgen 

Build and Sysgen Use when any OS source files are modified 

Rebuild and Clean Sysgen Use immediately after installing new QFE package(s) 

Build Current BSP and 
Subprojects 

Use when any BSP source files are modified or BSP registry 
changes have been made 

Rebuild Current BSP and 
Subprojects Performs a clean prior to "Build Current BSP and Subprojects"  

NOTE: In the menu, select Build > Global Build Settings. In the window that appears, make 
sure that both "Copy Files to Release Directory" and "Make Run-Time Image" options are 
selected. 

6.4 Run Logic PD’s Windows Embedded CE 6.0 BSP 

Please follow the steps below to download the newly created Windows Embedded CE image to 
your DM3730 Development Kit (the steps below assume the download is via Ethernet). 

1. Connect the DM3730 Development Kit to the Ethernet network. 

2. Connect the DM3730 Development Kit to your host PC using the null-modem serial 
cable included with the kit. 

3. Start Tera Term on your host PC. 

4. Power on your DM3730 Development Kit. 

5. Initialize LogicLoader’s TCP/IP stack and obtain an IP address from a DHCP server on 
the network.  

 
losh> ifconfig sm0 dhcp  
Starting DHCP on sm0 
 

6. Verify the device received an IP address.  

 
losh> ifconfig 
 
sm0: up   100M full duplex  (25) 
sm0:     mac: 00:08:33:02:38:79  ip: 10.0.5.119 
        mask: 225.225.252.0      gw: 10.0.4.1 
 

Note that the ifconfig command also displays the system MAC address. Occasionally, 
there is a brief delay before a kit obtains an IP address. Please verify that your 
development kit has received a valid IP address before proceeding to the next step. 
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7. Start the download process using the bootme & command, which sends UDP packets 
over the LAN to a host PC. The packets are recognized by Microsoft Platform Builder as 
coming from a device waiting to download a Windows Embedded CE image. 
Technically, the command is simply bootme; however, the & is needed to launch this 
command in the background so you may still interact with the LogicLoader shell. 

 
losh> bootme & 
Device's name is LoCE_14457. 
Sent BOOTME1 
 

As seen in the output above, the bootme & command outputs the name that the 
device will use to communicate with Platform Builder and then starts outputting 
network packets. 

8. Switch to Visual Studio 2005 and select Target > Connectivity Options.  

9. In the Target Device Connectivity Options window, select Ethernet in the drop-down 
boxes for both Download and Transport. 

 

10. Click Settings next to the Download drop-down menu. 
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11. Select the device’s name from the LogicLoader output in Step 7 above and click OK. It 
may take several seconds for the name to show up in the Active target devices: field. 
NOTE: The name of your device will almost certainly be different than that shown in 
the image below. 

 

12. In the Target Device Connectivity Options window, click Apply then click Close. 
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13. Select Target > Attach Device to download the Windows Embedded CE image to the 
DM3730 Development Kit. 

 

14. Platform Builder will download the new image to the DM3730 Development Kit. This 
may take some time depending on the network. 

15. When the download is complete, Platform Builder will wait for LogicLoader to connect. 

 

16. Once the image has been transferred, LogicLoader verifies the checksums and then 
returns to the losh> prompt. 

 
.......................................................................
.......................................................................
.......................................................................
.......................................................................
.......................................................................
.......................................................................
.......................................................................
............................ 
image launch addr: 0x801094b8 
 
Verifying checksums: >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> 
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
>>>>>>>>>>>>>> 
Checksums good.  
BOOTME: loaded 
BOOTME: Got a spurious packet.  
BOOTME: Got jump command 
losh> 
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17. Boot the image. 

 
losh> exec 
 

The output you see should look similar to the series of continuous screenshots 
presented below. Depending on the build options, you may see additional output; if 
not, wait for the image to boot and proceed to Step 18 below. 
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18. The DM3730 Development Kit LCD may ask you to calibrate the screen by using a 
stylus to touch the center of several crosshairs. Once the screen has been calibrated, 
tap anywhere on the screen and your DM3730 Development Kit will boot into Windows 
Embedded CE 6.0. 

 

6.5 Enable/Disable Drivers 

The table below provides information on how to enable and disable drivers with the Logic PD 
DM37x Windows CE BSP. Implementing any driver changes will require you to perform a 
Build > Advance Build Commands > Rebuild Current BSP and Subproject for the changes to 
take effect; the only exception is for enabling or disabling VFPU Support which requires a clean 
Sysgen (Build > Rebuild Solution). 

This section will show the basics of enabling and disabling a driver in the DM37x Windows CE 
BSP by walking through enabling and disabling the UART driver. Please refer to the individual 
driver documentation (found in the 10xxxxx_LogicPD_WinCE6_BSP_x-x-x\Documentation\ 
directory of the source BSP) for more details on using and customizing the DM3730 
Development Kit drivers. 
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Driver Action Display 

UART Enable Driver: Select catalog 
item for desired UART(S) under 
Third Party > BSP > 
LOGIC_SOM_DM37x: ARMVI > 
Device Drivers > Serial > UART 
 
UART1 
UART2 
UART3 
 
Disable Driver: Deselect catalog 
item. 
 
NOTE: In this example, you will 
see that UART1 has a radio button 
selection for either "UART1 Debug 
serial" or "UART1 Driver (COM1)." 
 
If you choose "UART1 Debug 
serial," then Windows CE will not 
have access to COM1 for serial 
communication. 
 
If you choose "UART1 Driver 
(COM1)," then Windows CE will 
have access to UART1 as the 
standard COM1 serial port. 
 
Debug serial is used to show 
debug messages from Windows CE 
and any of its drivers or 
applications that are running. 
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6.6 Customize Windows CE Image 

This section describes how to customize Logic PD’s DM37x Windows Embedded CE 6.0 BSP 
with built-in features. 

6.6.1 Use Onboard Bluetooth 

NOTE: This section only applies to the DM3730 SOM-LV Development Kit; the 
DM3730 Torpedo™ Development Kit does not support Bluetooth. 

This section will provide an example for how to connect a keyboard and mouse using the 
onboard Bluetooth module.  

6.6.1.1 Prerequisites 

■ This example uses the DM3730/AM3703 SOM-LV specific demo image project that is 
part of the Logic PD DM37x Windows Embedded CE 6.0 release. 

■ This section assumes the developer is already familiar with building Logic PD’s 
DM37x Windows Embedded CE BSP as described at the beginning of Section 5. 

6.6.1.2 Procedure 

1. Load the LOGIC_ARM_A8_SOM_LV_DM_10A.sln solution file into Visual Studio 2005. 

2. Select View > Other Windows > Catalog Items View. 
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3. Add Bluetooth HID Device Support by selecting the checkbox for the desired features. 
In this example, both "Bluetooth HID – Keyboard" and "Bluetooth HID – Mouse" are 
selected. 

 

4. Verify that the checkbox for "BFR6300 Bluetooth Driver" within the BSP is also 
selected. 
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5. Select Build > Build Solution. NOTE: Whenever a change is made in the Core OS 
Catalog components, a Build Solution is required; selecting “Build Current BSP and 
Subprojects” will not work in this case. 

6. Connect the antenna that comes with your DM3730 SOM-LV Development kit to the 
J3 SMA connector on your DM3730 SOM-LV. 

7. After loading your Windows CE image, select Start > Settings > Control Panel. 

8. Double-click the Bluetooth Device Properties icon. 

 

9. In the Bluetooth Manager window, click Scan Device. 

 

10. On the Bluetooth device you want to connect to your DM3730 SOM-LV Development 
Kit, click the pairing button. 
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11. Once the Bluetooth signal is detected from the device, it will appear in the Untrusted 
window. 

 

12. Click the ‘-->’ button to move your Bluetooth device to the Trusted window. In this 
example, the device does not required authentication so click No. 
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13. Double-click the Bluetooth device in the Trusted window and select Active to enable 
the it within Windows CE 6.0. 

 

14. If the device successfully activates, there will be a red check mark on the device icon. 

 

15. To add another Bluetooth device, repeat the instructions above beginning with Step 9. 
The image below shows both a Bluetooth mouse and keyboard successfully enabled. 
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6.6.2 Use a USB Bluetooth Dongle 

This section will provide an example of how to configure the BSP to use a USB Bluetooth 
dongle and not the onboard Bluetooth module. 

6.6.2.1 Prerequisites: 

■ This example uses the DM3730/AM3703 SOM-LV specific demo images project that is 
part of the Logic PD DM37x Windows Embedded CE 6.0 BSP release. 

■ This section assumes the developer is already familiar with building Logic PD’s 
DM37x Windows Embedded CE BSP as described at the beginning of Section 5. 

6.6.2.2 Procedure 

1. Load the LOGIC_ARM_A8_SOM_LV_DM_10A.sln solution file into Visual Studio 2005. 

2. Select View > Other Windows > Catalog Items View. 
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3. Add Bluetooth HID Device Support by selecting the appropriate checkboxes. In this 
example both "Bluetooth HID – Keyboard" and "Bluetooth HID – Mouse" have been 
selected. Also select "Bluetooth Stack with Integrated USB Driver," as this is required 
when using a USB Bluetooth dongle. 

 

4. Verify that the checkbox labeled "BFR6300 Bluetooth Driver" within the BSP is not 
selected; Windows CE 6.0 only supports one Bluetooth controller at a time. 
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5. Verify that the appropriate USB host driver is selected, if applicable. Refer to the driver 
documentation to determine the appropriate drivers to select to enable USB Host 
support for your platform (individual driver documents are located in the 
10xxxxx_DM37x_WinCE600_x_x_x_Source\Documentation\ directory of the source 
BSP). 

 

6. Select Build > Build Solution. 

7. After the Windows CE image has loaded, connect the USB Bluetooth dongle to the 
USB host port on the DM3730 SOM-LV Development Kit. 

8. Select Start > Settings > Control Panel. 
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9. Double-click the Bluetooth Device Properties icon. 

 

10. In the Bluetooth Manager window, click Scan Device. 

 

11. On the Bluetooth device you want to connect to your DM3730 SOM-LV Development 
Kit, press the pairing button. 
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12. Once the Bluetooth signal is detected from the device, it will appear in the Untrusted 
window. 

 

13. Click the ‘-->’ button to move your Bluetooth device to the Trusted window. In this 
example, the device does not require authentication so click No. 

 

14. Double-click the Bluetooth device in the Trusted window and select Active to enable 
the device within Windows CE 6.0. 
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15. If the device successfully activates, there will be a red check mark on the device 
name. 

 

16. To add another Bluetooth device, follow the instructions above beginning with Step 10. 
The image below shows both a Bluetooth mouse and keyboard successfully enabled. 

 

6.6.3 Change RAM Configuration 

Beginning in version 3.0.2, Logic PD's DM37x Windows Embedded CE 6.0 BSP is distributed 
with the RAM configuration set by default to 256 MB. To change this configuration for the 
512 MB SOM, the following two files must be edited: 

■ C:\WINCE600\PLATFORM\LOGIC_ARM_A8\FILES\config.bib 
■ C:\WINCE600\platform\LOGIC_ARM_A8\src\inc\addrtab_cfg.inc 

These files contain the configuration settings for 128 MB, 256 MB, and 512 MB options. To 
select the correct setting for your SOM, uncomment the lines for the desired configuration and 
ensure the other configurations are commented. The semi-colon (;) is the comment character.  
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Below are examples of the configuration settings in each file for the 256 MB option (default). 

config.bib 

 
MEMORY 
;   Name                        VA          Length      Type 
    ARGS                        80000000    00200000    RESERVED ;  2MB     
    DISPLAY                     80200000    01000000    RESERVED ; 16MB - Frame Buffer Pointer 
    NK                          81200000    02000000    RAMIMAGE ; 32MB 
   ;RAM                         83200000    12E00000    RAM      ; 302MB    (512MB HW Configuration) 
    RAM                         83200000    0CE00000    RAM      ; 206MB    (256MB HW Configuration) 
   ;RAM                         83200000    04E00000    RAM      ; 54MB     (128MB HW Configuration) 
   ;CMEM_DSP                    86800000    01800000    RESERVED ; 24MB 

 

addrtab_cfg.inc 

 
g_oalAddressTable 
; LPD 2.0 Bring up - rename BSP_SDRAM_BANK1_ENABLE appropriately and use it to adjust for 
multiple SDRAM ICs. 
; LPD 2.0 Bring up - we choose to not set up SGX and L4 EMU  
;  DCD     0x80000000, 0x80000000, 352     ; SDRAM (512MB HW Configuration)  

                                                ; The reason it's not 512 is because of 
                                                        ; the 160MB of  the 160MB of register 
                                                        ;space declared below. 
   DCD     0x80000000, 0x80000000, 256     ; SDRAM (256MB HW Configuration)  
;  DCD     0x80000000, 0x80000000, 128     ; SDRAM (128MB HW Configuration)  
  DCD     0x96000000, 0x48000000,  16     ; L4 Core/Wakeup registers 
  DCD     0x97000000, 0x49000000,   1     ; L4 Peripheral 
  DCD     0x98000000, 0x68000000,  16     ; L3 registers 
  DCD     0x99000000, 0x6C000000,  16     ; SMS registers 
  DCD     0x9A000000, 0x6D000000,  16     ; SDRC registers 
  DCD     0x9B000000, 0x6E000000,  16     ; GPMC registers 
  DCD     0x9C000000, 0x40200000,   1     ; 62KB SRAM 
  DCD     0x9D000000, 0x5C000000,  16     ; L3 interconnect 
  DCD     0x9E000000, 0x0C000000,  16     ; CS1, LAN9221 
  DCD     0x9F000000, 0x1C000000,  16     ; CS6, ISP176X USB HC 
  DCD     0x00000000, 0x00000000,   0     ; end of table 
 

NOTE: The Windows CE OS only supports 512 MB of physical memory. In the 512 MB RAM 
configuration, there is only an additional 96 MB of RAM actually available over the 256 MB 
version due to the fact that the 512 MB physical memory allocation limit includes the 160 MB 
of register space for the DM3730/AM3703 processor. It is possible to gain an additional 
15-30 MB of RAM by compressing the register space allocation around the SRAM 
(0x40200000) and L4 peripheral (0x49000000) register spaces. 
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